Redsn0w Step-by-step UNTETHERED jailbreak for 4.2.1 (Mac only)

Discussion in 'iPad Hacks' started by silverblack, Feb 2, 2011.

  1. silverblack, Feb 2, 2011
    Last edited: Feb 6, 2011

    silverblack macrumors 68030

    silverblack

    Joined:
    Nov 27, 2007
    #1
    The following documented what I did to successfully jb (untethered) my iPad. Try it at your own risk.


    A) Requirements:
    1. iPad previously jailbroken, and with SHSH on file with Cydia for at least 4.2.1 and 4.2b3 in order for this method to work.
    2. A Macintosh computer (Sorry no Windows version of redsn0w yet)
    3. (Optional, but recommended) Willingness to lose your app settings as you should set up your iPad as new device to avoid potential problems. (However, there are a few apps in Cydia to save those data, and restore them manually later if you know how to)

    B) Gathering Files:
    1. Download the current iOS 4.2.1 ipsw file from Apple - iPad1,1_4.2.1_8C148_Restore
    http://appldnld.apple.com/iPad/061-9857.20101122.VGthy/iPad1,1_4.2.1_8C148_Restore.ipsw
    2. Download redsn0w_mac_0.9.7b6 from iPhone Dev Team
    3. Download iPad1,1_4.2_8C5115c_Restore.ipsw (google for link)
    4. Download Pwnage Tool from http://blog.iphone-dev.org/
    I used PwnageTool 4.1.3 Unlock Edition - PwnageTool_4.1.3_Unlock_Edition.dmg
    5. Download TinyUmbrella (ver 4.21.05)
    http://thefirmwareumbrella.blogspot.com/

    C) Preparation:
    1. Install TinyUmbrella, and launch the app with your iPad attached to Mac
    2. Click "Save SHSH" to get all files available from Cydia.
    3. Now go to the Advance Tab. Leave "Set Hosts to Cydia on Exit" as checked
    (Uncheck this in the future when you want a clean restore from Apple)

    D) Put your iPad in DFU mode and Restore to a fresh copy of iOS 4.2.1
    1. Unzip PwnageTool_4.1.3_Unlock_Edition.dmg, move the pineapple icon to your desktop (or in Application folder) and run it.
    2. Select the iPad, so there is a green check mark beside it.
    3. Click the DFU icon, and follow the instruction
    4. It will confirm when your iPad is in DFU
    5. Go to iTunes, hold OPTION button on keyboard and click Restore.
    6. Select the iPad1,1_4.2.1_8C148_Restore you downloaded
    7. After iPad started, leave connected to iTunes so it would activate.
    (Stop here, don't set up your iPad with iTunes)

    E) The jailbreak:
    1. Unzip the redsn0w, and drag the folder or the pineapple icon to desktop and launch it.
    2. Click browse and point it to your iPad1,1_4.2.1_8C148_Restore.ipsw
    3. Go Next, then select both "Install Cydia" and "Jailbreak Monte"
    4. Now point it to your iPad1,1_4.2_8C5115c_Restore.ipsw
    5. Next, read the instruction carefully (It instructs you to bring your iPad to DFU again)
    6. Follow the steps (timing is very important). If you mess up, just click 'back', and start over.
    7. When your iPad enters DFU, the app will do its job to jailbreak it.
    8. Hopefully everything will go well. It'll restart, and you are DONE!

    F) My Result
    It appears to be working flawlessly, just as it was with iOS 3.2. No problem with bluetooth or dropping wifi signals. From Cydia, I installed RetinaPad, Activator, Display Out, and FAkeClockUp, and they are working great. Multitasking working nicely. Airprint is working after I installed Airprint Activator (free) on my Mac.
     
  2. BookEmDanno macrumors member

    BookEmDanno

    Joined:
    Nov 9, 2010
    Location:
    State of ~Aloha!~
    #2
    Thank you for this excellent post and the precise requirements and steps you outlined.

    A couple of questions please...

    My iPad 3G is already on 4.2.1 and jailbroken. I essentially completed sections B, C and D. Can I just re-jailbreak my iPad and go straight to section E, step 3?That is select both "Install Cydia" and "Jailbreak Monte"?

    Aloha and Mahalo!
     
  3. silverblack thread starter macrumors 68030

    silverblack

    Joined:
    Nov 27, 2007
    #3
    I don't know as I haven't tried it. But if I were you, I would redo part D and give my iPad a fresh iOS before re-jailbreak.
     
  4. Theraker007 macrumors regular

    Joined:
    Mar 3, 2009
    #4
    I'm nervous to try this without seeing something on iphonehacks or something.. but looks promising
     
  5. silverblack thread starter macrumors 68030

    silverblack

    Joined:
    Nov 27, 2007
    #5
    Goggle for "Untethered 4.2.1 redsn0w 0.9.7b6 monte", you'll see similar procedures posted at various sites.
     
  6. tbmx macrumors newbie

    Joined:
    Sep 17, 2006
    #6
    I can confirm this works. I was on 3.2 JB and followed the steps exactly.
     
  7. BookEmDanno macrumors member

    BookEmDanno

    Joined:
    Nov 9, 2010
    Location:
    State of ~Aloha!~
    #7
    I can confirm as well that my iPad 4.2.1 is set free - JB'd and UNtethered!
    As I posted above, I was already JB'd, albeit tethered when I attempted your instructions starting from part E, step 3. Worked like a charm.

    Mahalos!
    :)
     
  8. mamema macrumors regular

    Joined:
    Jun 9, 2010
    #8
    is this:


    Needed to make it an unthethered jailbreak or is it just the usual "better save than sorry" approach?

    Cause i've never done this with my iphones and ipads since Iphone 1G and had never any problems......
     
  9. silverblack thread starter macrumors 68030

    silverblack

    Joined:
    Nov 27, 2007
    #9
    Just a precaution. Whenever people have problems after jb, the typical question is, did you set up your device as new after the jb. So I may as well just do it in the first place, but it is of course optional.
     
  10. GaresTaylan macrumors 6502a

    Joined:
    Nov 11, 2009
    #10
    Just wanted to say that this worked for me. Thanks.
     
  11. 0r30, Feb 4, 2011
    Last edited by a moderator: Feb 5, 2011

    0r30 macrumors 6502

    0r30

    Joined:
    Aug 12, 2010
    Location:
    Texas
    #11
    Dint work for me , does this work on the Ipad 3g as well?


    I just got my ipad in december and have never jailbroken it or updated it..
     
  12. BookEmDanno macrumors member

    BookEmDanno

    Joined:
    Nov 9, 2010
    Location:
    State of ~Aloha!~
    #12
    I got my iPad 3G early Dec. It came with iOS 3.2.2. I was able to jailbreak it using limera1n, untethered. Then I upgraded to 4.2.1, jail broke it with Redsnow. This was tethered though. Last week, when i saw this excellent walkthrough, i went ahead an re-jailbreak using Redsnow and JB monte per instructions. Worked very well!

    What is your current iOS version when you attempted to JB your iPad 3G?

    ~ Aloha ~
     
  13. erillanos macrumors member

    Joined:
    Apr 2, 2010
    #13
    Worked Perfectly for me on iPad 16GB WiFI.

    The Greenpois0n rc5 was not working on my iPad so gave this method a try
    and it worked .

    Thanks for posting the guide.
    :):)
     

Share This Page