redsnow 3.01 jailbreak question (doesnt exist right?)

Discussion in 'Jailbreaks and iOS Hacks' started by markm75, Aug 26, 2009.

  1. markm75 macrumors member

    Joined:
    Nov 25, 2008
    #1
    I just had to have my phone replaced and now i have 3.01 firmware.. i had used redsnow to jailbreak 3.0 before..

    Do i just run the same process ontop of my 3.01 iphone? Any known issues to this?

    I've looked around, unless i missed it, there is no 3.01 jailbreak yet right?

    Thanks
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    I believe you can use the same jailbreaking tool as you did with 3.0. Someone correct me if I'm wrong.
     
  3. czarredd macrumors member

    Joined:
    Aug 25, 2007
    #3
    Your right..it's the same!
     
  4. Almy macrumors 6502

    Joined:
    Sep 27, 2008
    #4
    Yep, it's just as easy. Iirc, you just point it to the 3.0 ipsw. Everything else is the same.
     
  5. markm75 thread starter macrumors member

    Joined:
    Nov 25, 2008
    #5
    Worked out fine, i had the 3.01 clean firmware on there, ran the redsnow, pointed to 3.0 firmware.. then restored settings and ran apt and appbackup restores.. all back to normal...

    except two things are odd...

    The firmware in about reads 3.01 and i know have these small circles next to apps that are running in the background (is this a backgrounder enhancement or 3.01 enhancement)?

    And how is it 3.01, puzzled.

    works fine though
     
  6. Almy macrumors 6502

    Joined:
    Sep 27, 2008
    #6
    Yeah backgrounder has options now, and they recently became 3.0 compatible. You can click on it's icon and adjust settings.
     
  7. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #7
    I just can't get used to those new badges on Phone, Mail, and iPod, so I disabled. I don't keep that many things running in the background, and I use SBSettings processes to kill them if necessary.
     
  8. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #8
    Redsn0w doesn't replace your firmware, it just checks the ipsw file to make sure it is one it is compatible. It's a safety feature, to prevent Redsn0w bricking iPhones with incompatible firmware. Redsn0w hasn't been updated for 3.0.1, so it doesn't know about the 3.0.1 ipsw; but there is so little difference between the two that unlocking 3.0.1 with the same procedure works fine. Basically, you are tricking Redsn0w into thinking that you have 3.0 on your phone, so that it won't have conniptions about unknown firmware.
     
  9. mbopy22 macrumors 6502

    mbopy22

    Joined:
    Nov 8, 2005
    #9
    Hi, how do you do that? do you have to change your 3.0.1 Firmware name? to 3.0 only?
    Cause I restored to 3.0.1 then tried to JB with Redsn0w 0.8 but it keeps telling me that it dos not detect the ipsw, so I re JB with only 3.0
     
  10. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #11
    1) Download both the 3.0 and 3.0.1 versions of the firmware file to your Pwnage folder.
    1) Restore through iTunes with the 3.0.1 firmware.
    2) Open Redsn0w.
    3) When it asks you to select the .ipsw for your current firmware, select the .ipsw for 3.0 instead.

    I know it says it's important to select the one for your current firmware, but they are so similar that it will not affect the jailbreak.
     
  11. Skydivincoastie macrumors member

    Joined:
    Oct 31, 2008
  12. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #13
    Has worked on mine. Many times.
     
  13. Skydivincoastie macrumors member

    Joined:
    Oct 31, 2008
    #14
    I know the aluminum macbooks had a hard time putting the iphone into DFU mode...
     
  14. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #15
    That was with 10.5.6. This has been fine since 10.5.7 and 10.5.8. Dunno about 10.6

    EDIT: 10.6 is fine
     
  15. Skydivincoastie macrumors member

    Joined:
    Oct 31, 2008
    #16
    Guess ill give it a go...i upgraded to 10.6 on friday night...
     
  16. Skydivincoastie macrumors member

    Joined:
    Oct 31, 2008
  17. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #18
    You might want to try the LEOBADGE theme. It replaces the badge with an OSX-like glowing blue dot under the icon. Very unobtrusive.
     
  18. Rayfire macrumors 68020

    Rayfire

    Joined:
    Aug 25, 2008
    Location:
    PNW
    #19
    With 3.0 firmware it works fine, I just jailbroked my iPhone and so far looking good :cool:
     

Share This Page