redsnow crashing problem

Discussion in 'Jailbreaks and iOS Hacks' started by moonjockey, Jul 30, 2011.

  1. moonjockey macrumors newbie

    Joined:
    Oct 16, 2007
    #1
    Trying to jailbreak/unlock my iphone 3g running 4.2.1 with 5.15.04. I realize that I need to use redsnow to jailbreak and upgrade to ipad firmware.

    Downloaded 3 different versions of redsnow:
    redsn0w_mac_0.9.6rc16
    redsn0w_mac_0.9.6rc17
    redsn0w_mac_0.9.6rc18

    Even downloaded redsn0w_mac_0.9.6rc19 but it doesn't seem to have the option to upgrade to ipad baseband.

    I go into DFU mode. Redsnow recognizes. But while it says it's fetching the ipad firmware, it just disappears.

    Am I doing something wrong?

    Stats below:

    iphone 3g
    4.2.1 8c148
    firmware 05.15.04
    using macbook pro late 2007
    OS X 10.6.8

    Any help would be greatly appreciated. Going to England in 4 days and I want to use the phone there.
     
  2. moonjockey thread starter macrumors newbie

    Joined:
    Oct 16, 2007
    #2
    one other piece of info

    When Redsnow opens, I browse to the following file:

    home>library>itunes>iphone software updates>iPhone1,2_4.2.1_8C148_Restore
     
  3. moonjockey thread starter macrumors newbie

    Joined:
    Oct 16, 2007
    #3
    I solved the problem--but need ipsw help

    I found the iClarified site and downloaded the ipsw file that they had there, but the key was to find and download the redsnow version "redsn0w 0.9.6b6"

    Once I did this it worked perfectly. I now have a jailbroken and unlocked phone!!!

    Here's one thing I don't understand though. What do I need to do as far as restore files?

    Since the only restore file I have is the apple 4.2.1 restore with the old firmware, I'm assuming that won't work right? I feel like I read about custom ipsw, but where do I get that from?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    You create a custom ipsw using pwnage tool.
     

Share This Page