Redsnow is telling me I have the wrong phone

Discussion in 'Jailbreaks and iOS Hacks' started by peejer, Jan 12, 2011.

  1. peejer macrumors member

    Joined:
    Jan 12, 2007
    Location:
    TN
    #1
    I used to have a 3gs phone which I had JB with jailbreakme.com. Over Christmas I had to upgrade to a iPhone 4.0. Yesterday I backed up my phone to my iTunes account and then downloaded Redsnow and tried to begin this method of jail breaking. I located my ipsw and pointed redsnow to it but redsnow was telling me I had a 3gs still.

    I am using IOS 4.2. Snow leopard 10.6.6 and iTunes 10.1. My Ipsw shows that it was last updated in November which of course was when I had my 3gs. In iTunes I've updated my phone and it shows that it is up to date. Why doesn't my ipsw then show up as correct for my phone?

    This method is new to me and apologize for the newbie questions. I tried to search the web, but apparently I'm not down with the right lingo.
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    Which iPhone do you actually have? You used to have a 3GS, now what do you have?
     
  3. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #3
    You have to get the IPSW for the iPhone 4. You can't put the 3GS IPSW on the iPhone 4.
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    I concur with Ulbador. Here is what I think happen;

    You have updated your 3GS with the latest firmware. So, Mac has 3GS firmware on it.

    Since then, you got a new Iphone 4. Because it has 4.2.1 firmware on it. When you hook it to your Mac and Itunes check with Apple server and indicate that you have the latest firmware. Even your Iphone 4 has latest firmware, your Mac does not have this firmware copy. Only when you update to the latest firmware, that is when a copy of latest firmware get download to your Mac.

    In order for you to jailbreak your Iphone 4 with this latest firmware, you will have to get this firmware onto your Mac first. There are several sites that you can get it from beside Apple server.

    Good luck!
     
  5. ssdeg7 macrumors 6502a

    ssdeg7

    Joined:
    Jul 15, 2010
    #5
    That's the problem, IPSW are different for each device. Check the iPhone 4's IPSW
     
  6. peejer thread starter macrumors member

    Joined:
    Jan 12, 2007
    Location:
    TN
    #6
    I have the iPhone 4 currently. It is running IOS 4.2.1

    Why would my iTunes not have the latest firmware if I backed up my iPhone 4?
    And how can I then get the firmware I need? I don't understand why my firmware wouldn't update as well.

    Thanks
     
  7. crazycanucks macrumors regular

    Joined:
    Jun 30, 2010
    #7
    Download the firmware manually from here:
    http://www.iclarified.com/entry/index.php?enid=750
    You need to donwload this one: 4.2.1 (4): iPhone3,1_4.2.1_8C148_Restore.ipsw
     
  8. peejer thread starter macrumors member

    Joined:
    Jan 12, 2007
    Location:
    TN
    #8
    Thanks Everyone and especially Crazy canucks! Jailbroke again and purring right along.

    Happy New Years!
     

Share This Page