rEFIt not showing CDs; triple boot issue.

Discussion in 'Windows, Linux & Others on the Mac' started by GeeYouEye, Mar 24, 2009.

  1. GeeYouEye macrumors 68000

    GeeYouEye

    Joined:
    Dec 9, 2001
    Location:
    State of Denial
    #1
    I've got rEFIt installed, and a semi-successful triple-boot system: Leopard, Vista 64-bit, and XP 32-bit (partition order; XP was installed before Vista). I've got only two issues with it, which might be related.

    First, rEFIt hasn't shown boot discs since XP was installed. Second, I can't boot into Vista directly; Vista installed BOOTMGR to the XP partition, and is using that; I can only chain-load, which is precisely what I was hoping to avoid by using rEFIt.

    If they aren't related, any suggestions for fixing either one would be appreciated.

    If it's not possible to directly boot Vista, I'd just as soon uninstall rEFIt, but how do I know the XP partition will be the one that shows up when I press option at startup?
     
  2. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #2
    I tried a while ago to triple boot with xp osx and linux. Also used rEFIt but found not way to do it. Ened up unstalling rEFIt.
     
  3. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #3
    When I was triple booting Mac OS X/Windows/Linux I used a rEFIt/GRUB combo. rEFIt would handle booting into Mac OS X or booting of the GRUB partition, then the GRUB loader would allow me to choose either Windows or Linux. IIRC, rEFIt doesn't have the ability (yet) to do any sort of chainloading or drive swapping that is required to dualboot Windows properly.
     
  4. ilkevinli macrumors 6502

    ilkevinli

    Joined:
    Apr 8, 2006
    Location:
    NYC
    #4
    There is an issue with rEFIt and the newer MacBooks/Pro that prevent it from seeing bootable media (DVD/CD). The author is aware of it but said its going to be a while before it can be corrected because its going to take a whole rewrite of the software. The older MacBooks work fine.
     
  5. itopy macrumors newbie

    Joined:
    Jul 21, 2008
    #5
    Use an external CD drive

    I used an external USB CD/DVD drive. Put the OS install disc in first then turn on the computer. Worked for me but results may vary...
     

Share This Page