Regarding "Ignore accidental trackpad input"

Discussion in 'MacBook Pro' started by WorldChristian, Sep 4, 2008.

  1. WorldChristian macrumors newbie

    Joined:
    Jun 13, 2008
    #1
    I am a recent "convert" from long-time PC usage to a MacBook Pro. I regularly find, while typing, that my cursor is suddenly in a different place (along with what I am typing)--it is very frustrating. I have heard about this Tackpad option (under system preferences) that I can click (i.e., "Ignore accidental Trackpad Input"). Unfortunately, that option is not there where "they say" it is. The only option at the bottom of that Trackpad screen is: "Ignore trackpad when mouse is present" (am not using a mouse). Any idea where that option is, and whether that would help the problem I have??? Paul
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    You don't have the second bottom option in this picture (MacBook Pro, no external mouse plugged in)
     

    Attached Files:

  3. WorldChristian thread starter macrumors newbie

    Joined:
    Jun 13, 2008
    #3
    it is simply missing

    The "ignore accidental trackpad input" option is simply missing on my Trackpad screen
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    Peryn MBPs don't have this option.
     
  5. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #5
    Well there you go: mine is an original CoreDuo MBP.
     
  6. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #6
    Woa, I didn't know that. I guess it has to do with Multi-Touch, but what about accidental trackpad input? How does this affect accidental input?
     
  7. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #7
    Forgive the messed up screen shot, but as you can see, no accidental input, only ignore when external mouse is present.
    [​IMG]

    Regarding the mess: My multitouch drivers are messed up, but I'm too lazy to fix it.
     
  8. spdrcr5 macrumors newbie

    Joined:
    May 13, 2008
    #8
    I posted about this problem about a week or two ago. I have spoken with Apple support and they passed me onto a Manager who added me to a list of people who have complained about this issue. The only way this can be addressed is either Apple creating a patch/fix or someone being able to do this and share it with others.

    The first Apple tech I spoke with said I should just install an older version of OS X! lol
     
  9. anirban macrumors 6502a

    anirban

    Joined:
    Jan 9, 2007
    Location:
    Houston, TX
    #9
    That's news to me. Thanks for pointing that out!
     
  10. jgrevich macrumors newbie

    Joined:
    Sep 26, 2008
    #10
    Might this be something that can be activated using the 'defaults write' command in the terminal? Any idea what plist file we need to edit or where this setting might be stored?

    I checked ~/Library/Preferences/com.apple.systempreferences.plist to no avail.


    justin
     
  11. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #11
    You can't fix a hardware limitation through software
     
  12. jgrevich macrumors newbie

    Joined:
    Sep 26, 2008
    #12
    How are you sure it is a hardware limitation? What exactly is the HW limitation you are thinking about?

    This is something that has been an option in the majority of mac portables via a SOFTWARE configuration. What would prevent you from being able to turn off the trackpad while typing? Can people with Penryn MBP's turn it off using this ( http://www.macosxhints.com/article.php?story=20071121141206367 ) hack?

    If that works, at least we know the trackpad can be turned off. I am hoping for something more clean such as overriding a preference file.


    justin
     
  13. AquaMethod macrumors member

    Joined:
    Jun 17, 2008
    #13
    How the heck did that happen? I've used Input Managers to intercept the trackpad, and still haven't seen anything like that.
     
  14. Denarius macrumors 6502a

    Denarius

    Joined:
    Feb 5, 2008
    Location:
    Gironde, France
    #14
    This option seems to be available on my machine.
     

    Attached Files:

  15. Denarius macrumors 6502a

    Denarius

    Joined:
    Feb 5, 2008
    Location:
    Gironde, France
    #15
    Apologies for the crap screenshot in the last post, hopefully this one's better.
     

    Attached Files:

  16. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #16
    Did you even read the posts?

    You don't have the Peryn MacBook Pro that has a multi-touch trackpad..
     
  17. Denarius macrumors 6502a

    Denarius

    Joined:
    Feb 5, 2008
    Location:
    Gironde, France
    #17
    Focussed on Alphaod's comment about the Penryns. Missed that sentence about the multi-touch I'm afraid. Just as well I don't have one I guess. :)
     
  18. Denarius macrumors 6502a

    Denarius

    Joined:
    Feb 5, 2008
    Location:
    Gironde, France
    #18
    Plus the fact that I wasn't aware that not all Core 2 duos are Penryns. My bad.
     
  19. metroid87706 macrumors regular

    metroid87706

    Joined:
    Jul 2, 2008
    Location:
    New Baltimore, MI
    #19
    It should have it. My iBook G3 900MHz 14" had it..... :/
     

Share This Page