Regional settings messing up my .csv files

Discussion in 'Mac Basics and Help' started by Ingredients, Aug 23, 2010.

  1. Ingredients macrumors newbie

    Joined:
    Aug 17, 2010
    #1
    Hey,
    I was hoping someone would know a better workaround for a problem I'm having. When I export .csv files, it replaces the commas with semi-colons as the separators. The problem is described here.

    His conclusion is as follows;

    I'm hoping someone else might know a better solution for this instead of me having to go change my regional settings?

    Any help would be much appreciated :)
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Which application are you using to export the .CSV files? Odds are that application has a setting you can configure to work around this.
     
  3. Ingredients thread starter macrumors newbie

    Joined:
    Aug 17, 2010
    #3
    I'm using Excel for Mac 2008. I can't see any option to customise the usage of separators on it.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Well, lookie here... by golly, I think I found it.

    If you're using Snow Leopard, go to System Preferences -> Language & Text -> Formats tab -> Numbers section -> Customize button.
     
  5. Ingredients thread starter macrumors newbie

    Joined:
    Aug 17, 2010
    #5
    Well, when I go from United Kingdom (which is what I have changed it to to fix the .csv issue), back to Ireland, the Numbers formats don't change. So there must be some other element that isn't customisable that is effecting it.
     

Share This Page