Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

sandalwoodgrips

macrumors newbie
Original poster
Jun 12, 2013
6
0
I am a registered developer with a registered iPhone 5 A1428 UDID. Whenever I try to upgrade to iOS 7 beta iTunes gives me a message that says:

"The iPhone could not be restored. This device is not eligible for the requested build."

I am using an iPhone 5 A1428 and iTunes 11.0.4 with the proper iOS 7 A1428 ipsw file.
When trying to upgrade to iOS 7, iTunes fully extracts the IPSW, but the error occurs when "Verifying update with Apple". I do not understand the cause of this technical issue. Is anyone else having this problem and know how to resolve it?
 

Goldex

macrumors member
May 15, 2009
53
86
It can take a while for the UDID to get registered I think. I had the same issue yesterday when I "restored" to iOS 7, so I simply downgraded to iOS 6 by putting my iPhone in DFU, then I Alt+Updated to iOS 7. Works like a charm.
 
Comment

sandalwoodgrips

macrumors newbie
Original poster
Jun 12, 2013
6
0
I got this error when I did mine. I downloaded tiny umbrella and unchecked the boxes under the advanced tab and it worked. Found that solution on google


Can you explain what you did or what website you found this on? I've never used SHSH blobs from TinyUmbrella before.

It can take a while for the UDID to get registered I think. I had the same issue yesterday when I "restored" to iOS 7, so I simply downgraded to iOS 6 by putting my iPhone in DFU, then I Alt+Updated to iOS 7. Works like a charm.


Nope, still no luck. Same issue. :mad:
 
Comment

deuxani

macrumors 6502a
Sep 2, 2010
635
624
Are you sure you have an A1428? I'm from Europe (GSM only here) and thought I had an A1428 too and got the same error message. Then I looked on the back of my iPhone 5 and it seems to say A1429 :D Downloading the A1429 solved the error.
 
Comment

sandalwoodgrips

macrumors newbie
Original poster
Jun 12, 2013
6
0
Are you sure you have an A1428? I'm from Europe (GSM only here) and thought I had an A1428 too and got the same error message. Then I looked on the back of my iPhone 5 and it seems to say A1429 :D Downloading the A1429 solved the error.

Yes, definitely A1428. I'm a US AT&T user, and it says A1428 on the back of the iPhone! :p
 
Comment

sandalwoodgrips

macrumors newbie
Original poster
Jun 12, 2013
6
0
Does anyone know how to or where to read about fixing this technical issue with TinyUmbrella?
 
Comment

phansom7

macrumors newbie
Oct 17, 2012
28
0
UDID question

Has anyone ever paid to get their UDID registered by going onto a website and paying a smaller fee for the person add your UDID to get it activated???
 
Comment

mrapplegate

macrumors 68030
Feb 26, 2011
2,818
8
Cincinnati, OH
I am a registered developer with a registered iPhone 5 A1428 UDID. Whenever I try to upgrade to iOS 7 beta iTunes gives me a message that says:

"The iPhone could not be restored. This device is not eligible for the requested build."

I am using an iPhone 5 A1428 and iTunes 11.0.4 with the proper iOS 7 A1428 ipsw file.
When trying to upgrade to iOS 7, iTunes fully extracts the IPSW, but the error occurs when "Verifying update with Apple". I do not understand the cause of this technical issue. Is anyone else having this problem and know how to resolve it?

It might be better to post in the Apple developer forum.

The chances of an actual Apple engineer reading and helping you out increase dramatically.
 
Comment

cristovao

macrumors 6502a
Aug 20, 2010
555
7
Calgary
Can you explain what you did or what website you found this on? I've never used SHSH blobs from TinyUmbrella before.

It's quite simple and I just did it on my 5 successfully. Download Tiny Umbrella. Click the Advanced tab. Uncheck all the checkboxes. Exit. Option-Upgrade in iTunes and select the ISPW file and off you go.
 
Comment

macfrik

macrumors 6502
Mar 21, 2009
449
38
Utah
Does the OP ever fix the issue? I am having the same issue. Tiny umbrella and hosts trick turned to dead end. Please help.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.