iPhone Registered UDID; Update to iOS 7 from iOS 6 error. Please help!

Discussion in 'iOS 7' started by macfrik, Jul 29, 2013.

  1. macfrik macrumors 6502

    macfrik

    Joined:
    Mar 21, 2009
    Location:
    Utah
    #1
    I need help. I am trying to update my iPhone 5 to iOS 7 beta but keep on getting error on iTunes; "This device isn't compatible with the requested build" error. the UDID is registered on Apple's dev website using my brother's dev account. i"ve never jailbroken my iPhone and I tried to resolve the issue using the hosts trick but doesnt work still.

    I also tried restoring this phone on different Macs, still no luck

    Any ideas on might be causing this? anything would be much appreciated

    Thanks!!:apple:
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    And you are sure you are using the right build for the device?

    Have you tried both upgrading and restoring?

    Have you tried installing the new iTunes beta and using it for all of this?
     
  3. emckai macrumors regular

    Joined:
    Jun 24, 2013
    #3
    Are you sure you downloaded the correct IPSW for your iDevice?
    Double check and if you double checked, triple and quadruple check.
     
  4. zmagik macrumors regular

    Joined:
    Apr 3, 2013
  5. FirdausRocky macrumors newbie

    FirdausRocky

    Joined:
    Jul 5, 2013
    Location:
    Malaysia
    #5
    probably wrong version of downloaded ipsw..try to rechecked it..
     

Share This Page