Regular Crashes when Toggling "Auto. Graphics Switching"

Discussion in 'MacBook Pro' started by rhyzome, Mar 16, 2015.

  1. rhyzome macrumors regular

    Joined:
    Apr 2, 2012
    #1
    My mid 2014 15" rMBP (1TB, 16GB, dGPU) crashes regularly when I uncheck the "Automatic graphics switching" option in Energy Saver in System Preferences.

    Whenever I uncheck the button, I can move the mouse but clicking it anywhere does nothing; it's frozen. I always have to force restart.

    Anyone else have this problem?

    I feel really dumb for getting and now suffering through a dGPU rMBP when I don't game and only occasionally do very unsophisticated 1080p video editing (more like splicing/shortening/juxtaposing videos).
     
  2. hughw macrumors newbie

    hughw

    Joined:
    Jan 15, 2012
    Location:
    Bath/Bristol, UK
    #2
    this is a known bug - there's a fairly long post on the apple forums about it.

    There isn't very much you can do unless apple come out with a software update for yosemite.
     
  3. xiwong macrumors member

    Joined:
    Dec 9, 2013
    #3
    The thread on Apple Support is here https://discussions.apple.com/thread/6602046?start=0&tstart=0

    If you skim through, you'll see that most of the users with issues have dGPU rMBPs while there are less on 650M cMBPs and even fewer on the 2011 ATI models. For many users, installing the 10.10.3 update fixes the issue, but it has not for me. Considering I've had this problem since 10.9, I'm not sure its on Apple's radar.

    I would suggest you give the 10.10.3 public beta a go. Otherwise, disable Automatic Graphics Switching and the crash will go away. The reduced battery life and increased heat mean this is not a solution, but I would take those over poor system stability any day.
     
  4. rhyzome, Mar 16, 2015
    Last edited: Mar 16, 2015

    rhyzome thread starter macrumors regular

    Joined:
    Apr 2, 2012
    #4
    I see--as far as I can tell mine won't allow me _to disable_ automatically graphics-switching (I suppose that will save some energy, assuming it is doing what the checked box says) without crashing...I don't even know how I'd force it to stay in intensive mode. It crashes every time I hit that button.

    I also notice that I get frequent crashes just from starting iMovie, and sometimes (though much less frequently) Aperture. Do you get this as well?

    I wish I knew how to produce a "log" to see if there were "GPU reset events"...

    I'm a little afraid to use the public beta for the sake of the remaining stability of my files that's left...of course, the moment the actual 10.10.3 is released I'll be sure to install it and see if this persists.
     

Share This Page