iPad Reinstalling Cydia or uninstalling debs through SSH?

Discussion in 'Jailbreaks and iOS Hacks' started by egosheep, May 2, 2013.

  1. egosheep macrumors newbie

    Joined:
    May 2, 2013
    #1
    I recently got an iPad 3 wifi. It shipped with ios 5.1.1. I missed my window to install or jailbreak 6.1.2, but went ahead and jailbroke it on 5.1.1. My problem is this: in anticipation of the ipad arriving, I had been collecting tweaks and deb files to add to it, and by mistake I installed like 12-13 at once by putting them in the autoinstall folder in cydia(dumb... i know). I was stuck in a safe mode loop for a while until I deleted them from the mobile substrate which allowed me to get out of safe mode. Unfortunately Cydia will not let me uninstall any of these tweaks/apps. It hangs on a 403 error on any uninstall attempts. I tried to do a fresh install of Cydia but now it crashes upon opening it.

    Is there any way I can manually use SSH or iFunbox to flush out all the added .deb tweaks and restore Cydia to a vanilla version? I have tried uninstalling in ssh with dpkg -r but I can never get the file name just right, and can't see the whole thing when I list them with dpkg -l. Can I go folder by folder, delete it all, and then reinstall cydia with redsn0w? Or is there some other way?

    I would just reformat but unless I'm mistaken there is no way to go cleanly back to 5.1.1 at this point. The ipad is now stable and working fine otherwise but it's a big loss to not have Cydia, winterboard etc. Any help or tips would be appreciated!
     
  2. nepalisherpa macrumors 68020

    nepalisherpa

    Joined:
    Aug 15, 2011
    Location:
    USA
    #2
    This might help: http://forums.macrumors.com/showthread.php?t=1568493
     
  3. egosheep thread starter macrumors newbie

    Joined:
    May 2, 2013
    #3
  4. egosheep thread starter macrumors newbie

    Joined:
    May 2, 2013
    #4
    It worked great, thanks so much. Cydia is still not working but everything is cleared out from settings. Now I just need to figure out how to reinstall cydia.
     
  5. Missjenna macrumors 6502a

    Missjenna

    Joined:
    May 10, 2010
    Location:
    Oregon
    #5
    One of the options for ilex rat is to reinstall cydia :)
     
  6. egosheep thread starter macrumors newbie

    Joined:
    May 2, 2013
    #6
    That's the one option that isn't working.
    getting this error:
    usr/bin/rat-run: line 128: apt-get: command not found
     
  7. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #7
    i think iOS 5 runs cydia v1.1.6. here's the download link: http://apt.saurik.com/cydia/debs/cydia_1.1.6_iphoneos-arm.deb

    i don't know if that will help you though
     

Share This Page