Rejailbreaking iPhone 4S

Discussion in 'Jailbreaks and iOS Hacks' started by LoMayoKicksU, Jun 22, 2013.

  1. LoMayoKicksU macrumors member

    LoMayoKicksU

    Joined:
    Apr 17, 2011
    #1
    I have an iphone 4s 6.1.2 jailbroken using evasi0n(older version).

    Is it ok to jailbreak it again without upgrading to 6.1.3 but using the latest version of evasi0n? Please advise of any cons in doing so because I don't want to brick my phone.

    How about using another tool? Please suggest if it is possible.

    Thank you.

    NOTE: Speakerphone works perfectly but no sound when playing music.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    You can't jailbreak iOS 6.1.3 on an iPhone 4S.
     
  3. LoMayoKicksU thread starter macrumors member

    LoMayoKicksU

    Joined:
    Apr 17, 2011
    #3
    Sorry but you misunderstood me. I want to run a jailbreak on it again on 6.1.2.

    It is already jailbroken on 6.1.2.

    Is it ok to run a jailbreak twice on the same 6.1.2? Any cons???
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    There's no need to run evasi0n again. Just update it through Cydia.
     
  5. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #5
    What would that accomplish? :confused:
     
  6. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #6
    Why would you want to run the jailbreak a second time?
     
  7. Troneas macrumors 65816

    Troneas

    Joined:
    Oct 26, 2011
    Location:
    At the alternatives section.
    #7
    evasion updates itself through cydia.

    if you can boot your jailbroken phone with no problems and have a cydia icon somewhere on your springboard what more do you want to accomplish with this re-jailbreak?
     
  8. Sital macrumors 68000

    Sital

    Joined:
    May 31, 2012
    Location:
    New England
    #8
    I think he is, misguidedly, hoping it will fix his "no sound when playing music" issue.
     
  9. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #9
    I have rejailbroken three times. I haven't had any problems. You should also run ilex rat to clean up the device.
     
  10. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #10
    What makes you think rejailbreaking will solve your 'no sound' issue?
     
  11. LoMayoKicksU thread starter macrumors member

    LoMayoKicksU

    Joined:
    Apr 17, 2011
    #11
    I am thinking of a few possibilities:
    1. The older version of evasi0n had some bug in it that affected the sound and am hoping that the latest version will fix it.

    2. Jailbreaking deletes everything and the phone starts fresh again. So I am hoping that this could be a possibility of fixing the sound problem.

    NOTE: Before I started everything on my first note above, I uninstalled all the apps that I have installed but it did not help at all.

    How about running a different jailbreaking tool on top of the evasi0n? Will this brick the 4s?
     
  12. JPNFRK7 macrumors 6502

    JPNFRK7

    Joined:
    Sep 27, 2012
    Location:
    California
    #12
    There isn't another tool that jailbreaks iOS6.
     
  13. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #13
    1) no bugs that would cause any sound problem

    2) jailbreaking again does not mean fresh phone, everything stays the same.

    Did you try to put it in saf-mode and see if the sound problem persists.
    If it does it is most probably a hardware problem if it does not have any problem in safe-mode try ILEX RAT to get rid of all unnecessary jailbreak tweaks.

    To go in safe-mode turn it off and while holding volume-up press power.
    Keep holding volume-up during the boot process.
     
  14. LoMayoKicksU thread starter macrumors member

    LoMayoKicksU

    Joined:
    Apr 17, 2011
    #14
    I just did and the problem persist. But as I mentioned before, the speakerphone works perfectly but anything else fails to use the speakers. There are times that I will be able to hear the speakers between 1-15 seconds and this is usually after a reboot, then the sound will suddenly go away.

    Should I try ILEX RAT?

    Please advise.
     
  15. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
  16. LoMayoKicksU thread starter macrumors member

    LoMayoKicksU

    Joined:
    Apr 17, 2011
    #16
    After ILEX RAT, the sound of my music lasted about 6 minutes then it was gone again.

    I think I will try semi restore. Please let me know if there is any very bad CONS on this one.

    Thanks again.
     
  17. TNT93 macrumors newbie

    Joined:
    Apr 21, 2013
    Location:
    Northampton, UK
    #17
    I believe this is a hardware issue in the phone thinking its docked, has happened to both my mum's and dad's iphones, some say cleaning out the dock connector thoroughly has fixed the issue but it hasnt fixed my parents, what i've done to theirs is add http://exile90software.com/cydia/ install icleaner pro, open it up and go to the 2nd tab along the bottom and I believe it's the accessory deamon, turn this off and click apply. hopefully this solves your problem however it may be of no use as it renders accessories other than chargers unusable which isn't a problem for my parents.
     
  18. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #18
    I concur
    Hardware issue
     
  19. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #19
    It's pointless to rejailbreak it. If there was a bug in the first evasi0n software, you will just have to update it in Cydia and it should be fixed.

    Bring it to Apple and see what they say.
     
  20. LoMayoKicksU thread starter macrumors member

    LoMayoKicksU

    Joined:
    Apr 17, 2011
    #20
    I tried ILEX RAT and Semi Restore but it didn't work at all.

    iCleaner Pro did not sound that good becauase of this "however it may be of no use as it renders accessories other than chargers unusable which isn't a problem for my parents." but it did work like magic and everything works now hahaha... and the good thing is that the accessories still work(headset and blutooth).

    Thank you sooooo much dude.
     
  21. TNT93 macrumors newbie

    Joined:
    Apr 21, 2013
    Location:
    Northampton, UK
    #21
    glad to know it worked for you, I believe it's quite a common issue. And yes headset and bluetooth should still work as you said, I think it just disables accessories that use the dock (stereos, radios etc.) which isn't an issue for the parents and as both of their phones are out of warranty it's not worth them paying for a replacement :)
     
  22. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #22
    That's awesome dude. FYI, when it says accessories, it means accessories connected via the dock, not the headphone jack. Enjoy your fixed device!
     

Share This Page