Relaying

Discussion in 'macOS Sierra (10.12)' started by AusS2000, Jun 12, 2018.

  1. AusS2000, Jun 12, 2018
    Last edited: Jun 15, 2018

    AusS2000 macrumors newbie

    Joined:
    Nov 12, 2009
    #1
    I have a Mac running OS X Sierra Server (5.3.1).

    The Mail section is a bit dumbed down on previous versions. There is no GUI option to 'Allow relaying from:'.

    I believe this is actually Postfix and that with Postfix you allow relaying in the main.cf 'mynetworks' section.

    There are three postfix/main.cf files:
    /Applications/Server.app/Contents/ServerRoot/Library/Server/Mail/Config/postfix/main.cf
    /Library/Server/Mail/Config/postfix/main.cf
    /private/etc/postfix/main.cf

    I have edited all of them but still no luck. Anyone know what I am doing wrong?
     
  2. AusS2000 thread starter macrumors newbie

    Joined:
    Nov 12, 2009
    #2
    In answer to my own question, the instance of Postfix in use by Server is:
    /Library/Server/Mail/Config/postfix/

    Edit the file:
    /Library/Server/Mail/Config/postfix/main.cf

    You need to uncomment the line:
    mynetworks = 127.0.0.0/8, xxx.xxx.xxx.xxx/24
    And add any networks or addresses you require to it.

    Then, scroll to the bottom of the document. There you will find the settings that Server actually uses.
    Look for the one that starts with:
    smtpd_recipient_restrictions =

    You need to add 'permit_mynetworks'

    smtpd_recipient_restrictions = permit_sasl_authenticated permit_mynetworks reject_unauth_destination permit

    Restart the service.
     

Share This Page