Release: Zeus Flashing Tool

Discussion in 'Mac Pro' started by Cindori, Mar 12, 2010.

  1. Cindori, Mar 12, 2010
    Last edited: Mar 11, 2011

    Cindori macrumors 68040


    Jan 17, 2008

    What is Zeus?

    Zeus is a Mac GPU Flashing Tool. It can write a new firmware on to your graphic card.
    But it can do much more then that. You can patch your drivers to add support for excotic cards,
    install injectors by Netkas, and save the firmware from your Nvidia card.

    Zeus is the replacement for ATI Flashing Tool.

    New Features in Zeus:

    Modify 4870 / 4890 firmware to add EFI
    Disable Power Warning
    Overclock some Nvidia cards



    You can find my blog at


    My thanks to specially, Netkas, Rominator and Pipomolo for providing with key elements in creation of this app.

    My even more special thanks to Donaters, for without them the app would have stayed at ATI Flashing Tool 1.0

    You can donate to Zeus and it makes me very happy.



    Flashing and Dumping Nvidia only works on the Nvidia card in the bottom slot. It's recommended not to use these functions with two Nvidia inside the computer.
    1. Open Zeus
    2. Select Nvidia tab
    3. Browse for ROM
    4. Click Flash


    1. Open Zeus
    2. Select ATI tab
    3. Select OS
    4. Browse for ROM
    5. Click Flash

    HOW TO MAKE 4870 / 4890 ROM:

    1. Install windows, or just boot from a Windows disk. Not VMware!

    With the ati card inside, and drivers installed in windows

    2. Download GPU-Z for windows

    3. Click the icon next to BIOS VERSION. Save your firmware.

    4. Send the firmware to your mac disk. Reboot OSX.

    5. In Zeus, go Firmware, browse for the firmware, select card model

    6. Click Apply!

    Further reading:

    The Golden Guide to Flashing Graphic Cards

    That thread is a little old though!

    As always... use on your own risk...
  2. bearcatrp macrumors 68000

    Sep 24, 2008
    Boon Docks USA
    What cards are supported for flashing? Checking to see if the 5000 series ATI cards can be done.
  3. GMink macrumors regular


    Feb 10, 2010
    You will be able to flash the 5000 series IF Apple offeres one as an upgrade. Right now no support in OSX. I'm sure when they release a new MP that a new performace video card will be offered eventually.
  4. Eithanius macrumors 65816

    Nov 19, 2005
    Good work Cindori. This is what I'm looking for.

    However there's a mention that in order to flash an nvidia card, it is not recommended to have 2 nvidia cards installed. I assume I have to use an ATI instead for display while flashing an nvidia card.

    Presumably if I were to flash a generic nvidia GTX 285, flashing it won't be possible on a 128K rom chip unless it is replaced by a 256K. Does it still apply here...?
  5. hosko macrumors newbie

    Mar 4, 2010
    I'm slightly confused.

    If I have a Mac Pro with a stock GeForce GT 120 and I want to use a PC GeForce GTX285 1GB card do I only need to use Zeus and nothing else? Also do I have to take the 120 out before hand??
  6. iamcheerful macrumors 6502


    Oct 3, 2008
  7. Cindori thread starter macrumors 68040


    Jan 17, 2008
    bearcatrp: This app should support every ATI card. This is not the case however, SOME cards (some as in very few, i've seen about 3-4) are not recognized correctly in OSX. So they are not recognized as ATI cards, so the Flasher wont find them.

    Since the app only looks for ATI cards there is a big chance this will work for the 5800 series too. I guess someone can test, by dumping their PC 5870 rom, then maybe do 1 tiny fan mod, then try flash it with my app (rom has to be different to card in order for the flash to go trough)

    Eith: The nvidia flasher acts different from the ATI flasher.
    The ATI flasher will try to match the ROM file to the right card, avoiding to flash wrong one. But the nVidia flasher will try to flash the nvidia card in the lowest slot. So instead of asking to put the flash card in Slot 1, I simply prompt the user to use only 1 card, avoiding ALL mistakes.
    Also, the Nvidia flasher can only flash Mac cards. The card has to be initialized (i.e be running properly) for the flasher driver to detect it.
    So, flashing PC cards won't work (perhaps if the card is injected with netkas mods)

    Hosko, no. You can not make the 285 GTX work with Zeus unless you solder a new firmware chip on it.
  8. AryGoldman macrumors newbie

    Mar 18, 2010
    Damn, i messed it up

    First of all thank you for your great work, all the tips and instructions on flashing.
    Please keep up the great work!

    So here’s my dilemma:
    I bought a Sapphire Radeon HD 4870 1GB GDDR5 (PN: 288-1E131-000SA, SKU: 11133-19) to upgrade my MacPro 1,1.
    Ordered the two pcie-cables, installed the card, flashed it with the ATI-Flashing tool and the provided „mac modified.ROM“.

    Had the power-cable-warning on startup but didn’t mind as i had read not to do so. Everything seemed to work great but when i played bioshock (mac edition) with all settings on max i noticed red-green-blue pixel artifacts/errors flickering all over my screen sometimes leading to complete freezes.

    Issue could only be solved restarting the machine so i downloaded the new zeus-tool and installed another rom found here in the forums. Flashing completed w/o errors, but my machine would no longer start up. All i got is a repeating startup-chime, so i had to completely remove the card from my macpro in order to power it up.

    Any suggestions on how to get the thing back to work?

    thank you,
  9. Cindori thread starter macrumors 68040


    Jan 17, 2008
    try with mac card running display and PC card in another slot. if no dice, go bootcd method. described in my guide.
  10. AryGoldman macrumors newbie

    Mar 18, 2010
    Cindori, thanks for the advice.
    i tried with the mac card running display in pci-slot 1 (bottom) and the 4870 in slot 2. no repeating startup-chime but black screen/no video and some red led went on on the motherboard.
    sorry to bother you but what exact guide do you mean for bootcd method?

    thx in advance,
  11. Cindori thread starter macrumors 68040


    Jan 17, 2008
  12. AryGoldman macrumors newbie

    Mar 18, 2010
    seems i got a serious issue. made the bootcd as described here ( plugged in the 4870 but my mac won´t boot as long as the card is installed even though i have the display on the stock 7300 gt.
    having the 4870 in slot 1 gives me the repeating startup-chime.
    stock 7300 gt in slot 1 (running display) and 4870 in any other slot - normal startup-chime but black screen and red LED indicating CPUB on motherboard (just underneath the housing of the dimm raisers) goes on.
    damn i hope i didnt just waste the card and money...
  13. Cindori thread starter macrumors 68040


    Jan 17, 2008
    set startup disk to boot disk before you insert card
  14. MacVidCards Suspended

    Nov 17, 2008
    Hollywood, CA
    Repeating startup chime...or startup chime that doesn't even complete before repeating is usually only resolved by reflashing in a PC.

    If you are in Los Angeles area, I will fix any such issue for a six of Stella.

    If Pipomolo42 or any other higher level genii read this, the one thing Zeus is still in desperate need of is a DUMP tool.

    There was an ATI ROM dump for PPC. My guess is that one exists or functionality could be enabled for Intel.

    Ideally, everyone would dump their ROM before flashing. It is the only wy to be 100% certain that your finished ROM is the best possible match for your card.
  15. Cindori thread starter macrumors 68040


    Jan 17, 2008
    I tried have a look at the romdumper for powermac, but couldnt make heads or tails of it. It seems to load a older version of the driver in zeus, but also loads a driver that looks to be created by Thomas Perrier. But I cant access the dumper app bundle for some reason. It doesnt even look like its a binary.

    if pipomolo42 made a script to check for 7C, 7D, or 7E and then adjust the tables accordingly, I could implement that together with the rest of his romwriting scripts to create a Rom Creator right inside zeus. I would myself but don't have enough python knowledge. I'm sure its easy.
  16. AryGoldman macrumors newbie

    Mar 18, 2010
    thx for your kind advice. it is so great to have you arround trying to help me. feeling less frustrated, even though no progress made ;-)

    i installed winxp in order to get my bootcd done, then selected the bootcd as startup (in winxp). pwrd down, installed 4870 in slot 2, stock gt120 in slot 1 driving display, normal startup-chime, black screen, dvd-drive starting to work, red led indicating cpub failure went on, no further startup even after waiting 10 minutes or so and having tried all different dvi-ports.
    so since i dont get the machine running w/card the only thing is to flash it w/pc (which i dont have), right? I dreamed about simply putting the card in w the machine running last night, but assume that wont be a good idea...

    unfortunately im not even close to los angeles area, but thx a lot for the offer. mybe you´d like to see me for oktoberfest (munich) and bring your stuff? just kidding, i don´t want to wait that long ;-)
  17. joeco macrumors member

    Jul 10, 2008
    Hi cindori

    I have a 4870 hd ready to flash but seem to have a few problems.
    When in windows the gpu-z tool wont let me save the rom, and when booting into osx with my 8800 in slot 1 and my 4870 in slot 2 I get a kernel panic telling me to shut down.

    Any ideas and help would be much appreciated.

    Thanks in advance.
  18. Cindori thread starter macrumors 68040


    Jan 17, 2008
    looks like some cards are doing that

    look up atiflash for dos and how to dump roms with it
  19. joeco macrumors member

    Jul 10, 2008
    Managed to save the rom, it worked by plugginf the monitor cable into the ati gfx card? Still either getting kernel panic or card not being seen in osx though. Any help on the last hurdle?

    Thanks again.
  20. GaryREM macrumors newbie

    Oct 2, 2009
    How soon until 10.6.3 update to Zeus (10.6.3 is out now)? (Note, I was running 10.6.3 seed and tried to add info to the kext but still couldn't get QE/CI to run :( ).

  21. quantum003 macrumors 6502a


    Apr 27, 2009
    Cindori- THANK YOU. Your tools and guides are priceless. It's a great thing you're doing by making them available to common folk such as myself. :)
  22. llatker macrumors newbie

    Jul 11, 2007
    Update Error!

    Cindori- THANK YOU. Zeus Looks like a great app. I used your AtI Flashing Tool when 10.6.2 came out. I have Zeus 1.1 and tried updating it, but get an error: "The update is improperly signed," so I can't use it and update to 10.6.3.

    Any idea what the error is and how to update to Zeus 1.2 – the download link on the Zeus page still downloads v 1.1.


  23. Cindori thread starter macrumors 68040


    Jan 17, 2008
    The download link points to a fixed 1,1 version - which doesnt have the Improper Signed Update error.
  24. MacProMovie macrumors newbie

    Mar 31, 2010
    Zeus + Sapphire 11133-04-20R + No BIOS = ???

    I may have done something very stupid. Before flashing, the card was recognized as working in second slot up from main 7300 card.

    I then "flashed" it with Zeus, but didn't browse/pick a BIOS. It took a few moments and said that I had successfully flashed it.

    No matter what slot the Sapphire 11133-04-20R is in, it has startup chime and then gets stuck in a startup chime loop.

    Did I toast the card because I didn't pick a BIOS file?

    I've since found a BIOS on the forum here for that card, but I can't flash it because I can't boot the Mac Pro with the Sapphire installed.

    Thanks for any help! And thanks Cindori!

    Just read this: "...if no dice, go bootcd method. described in my guide." Will give this a try.
  25. Cindori thread starter macrumors 68040


    Jan 17, 2008
    there is a little flaw with zeus. if you flash with no browsing, the last rom file will be used. maybe you didnt flash before, but it might have been left a rom since I uploaded the app. going to be fixed in an update.

    so your card is not broken, just flashed with incompatible rom. bootcd method will work.

Share This Page