Remembering passwords

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jbrown, Dec 19, 2014.

  1. jbrown macrumors 6502a

    jbrown

    Joined:
    Jul 7, 2002
    Location:
    London
    #1
    A small but annoying problem - hoping someone knows a fix.

    I have a few regular websites the require a password. They give me the option for my device to remember me so I don't have to log in each time I visit them.

    This works fine on my MacBook pro, and iPad.

    But not on my iPhone 6 ( or previous 5s ). It will remember me for a few hours, then forget me!

    Any solution to this...it's annoying! :)
     
  2. KohPhiPhi macrumors 6502a

    Joined:
    Feb 9, 2011
    #2
    There are apps that manage all your passwords off a single master password "to rule them all" ;D . The one I use is called 1-password and it syncs my passwords from my laptop to iphone (and viceversa).
     
  3. PsyOpWarlord macrumors 6502

    PsyOpWarlord

    Joined:
    Nov 11, 2010
    Location:
    Colorado Springs, CO
    #3
    I second having 1Password.

    However you are having an issue with one device not using the Keychain properly.

    http://support.apple.com/en-us/HT203783

    Scroll down and I would start here at:
    iCloud Keychain isn't syncing with other devices.

    Make sure that your device is on a Wi-Fi or cellular network. If the connection appears strong, try these steps:

    Turn off iCloud Keychain on all devices.
    Turn on iCloud Keychain on the device that has the most up-to-date keychain items.
    Turn on iCloud Keychain on your other devices. They will be updated with your new iCloud Keychain.

    _____________________________________________________
    Then I would check
    Safari isn't automatically filling in account names and passwords on some websites.
    iOS 7.1.1 or later:

    Go to Settings > Safari > Passwords & AutoFill and make sure that Names and Passwords is on.
    Go to your Home screen and open Safari. If Safari is black or dark instead of white or gray, Private Browsing is on. Safari doesn't save account names and passwords when Private Browsing is on. To turn off Private Browsing:
    On iPad, tap the the plus icon in the upper-right corner of the Safari page, then tap Private in the lower-left corner.
    On iPhone and iPod touch, tap Tabs icon in the lower-right corner of the Safari page, then tap Private in the lower-left corner.
    OS X Mavericks v10.9 or later:

    Choose Safari > Preferences, then click Passwords.
    Select AutoFill user names and password.
    Open the Safari menu and see if Private Browsing is selected. Safari doesn't save account names and passwords when Private Browsing is on.
     
  4. Primejimbo macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
    #4
    Another one for 1Password. Been using it for over a year now and we'll worth the money and probably my favorite app I ever got.
     

Share This Page