Remote app and Apple TV4 - so confused

Discussion in 'Apple TV and Home Theater' started by amro, Oct 2, 2016.

  1. amro macrumors 6502

    Joined:
    Jul 7, 2008
    #1
    I'm on the latest with everything; tvOs, iOS, iPhone 7 Plus, ATV4
    Both devices are on the same WiFi (after I tried with the Apple TV on hardline)

    The app can never find the AppleTV. But strangely enough, whenever I get to a text input, my iPhone pops up a window and lets me type.

    Am I missing something? This seems to be the only Apple app that gets worse over time.
     
  2. benjitek macrumors 6502a

    benjitek

    Joined:
    Sep 23, 2012
    #2
    Sounds like something's misconfigured on your side. Probably would be best to give AppleCare tech support a call.
     
  3. leesweet macrumors demi-god

    leesweet

    Joined:
    Feb 1, 2009
    Location:
    Northern Virginia, USA
    #3
    The popup is working via Bluetooth, I believe. I had this happen when I changed the wifi password for my AEBS and had to change every device, of course. The popup was a great way to paste in the new password.

    If the remote app can't find the ATV, sounds like it's not on the same wifi. If that's not possible, yeah, a call or chat is in order.
     
  4. amro thread starter macrumors 6502

    Joined:
    Jul 7, 2008
    #4
    Ok, thanks. Yeah, they're on the same WiFi. I rebooted everything including the router. I might simply try a restore first. I haven't added too much, so it should be fairly quick.
     
  5. NYMinute macrumors newbie

    Joined:
    Nov 21, 2011
    #5
    Are you using the Remote app (blue and gray with a triangle) or the new Apple TV Remote app (black and gray with the apple logo and the letters "tv")?
     
  6. amro thread starter macrumors 6502

    Joined:
    Jul 7, 2008
  7. razorme macrumors regular

    razorme

    Joined:
    Jul 16, 2002
    Location:
    Calgary, AB
    #7
    Double check that ATV 4 software is up to date. Mine didn't work with Remote App out of the box.
     
  8. NYMinute macrumors newbie

    Joined:
    Nov 21, 2011
    #8
    If everything is up to date the next thing I would do is:

    1. Log out of your icloud account on the Apple TV
    2. Unplug it for 15 sec
    3. Turn off your phone and turn it back on
    4. Plug in your Apple tv
    5. Log back to your icloud account
     
  9. IxRich macrumors newbie

    IxRich

    Joined:
    Apr 9, 2016
    #9

    I'm having this exact same problem. I called the Apple TV secondary support tier. We went through all the trouble shooting steps and could not get it fixed.

    He's escalated to the engineering team to find out why the app won't see the AppleTV.

    Strange thing is, the old remote app, works perfectly. Even upon resetting the AppleTV, it found the phone perfectly and transferred across all account and wifi data instantly from the phone.

    It sounds to me that there's either a bug with TVOS10 or with the Apple TV Remote App, or both.
     
  10. Hal~9000 macrumors 68000

    Hal~9000

    Joined:
    Sep 13, 2014
    #10
    I got an ATV4 today which had 9.0 out of the box so it wouldn't show up in the iPhone Remote app.

    A quick restore / update of the ATV4 to 10.0 and the remote app is working perfectly now :)
     
  11. amro thread starter macrumors 6502

    Joined:
    Jul 7, 2008
    #11
    I'll try more testing tonight. I had an issue with my iBeacons not being discoverable on my phone yesterday and ended up doing a Bluetooth off, hard reset and Bluetooth on the phone. After that, my iBeacons were discoverable. I don't think it's a Bluetooth error, but I certainly want to see if a simple hard reset on the phone changed anything.
     
  12. amro thread starter macrumors 6502

    Joined:
    Jul 7, 2008
    #12
    Hard reset on iPhone didn't help. Reset and restore didn't help either.

    Saw your mention of the older Apple TV app. Works like a champ. Just confirms Apple's new app is garbage. What's it supposed to do better than the old app?
     
  13. Prototypical macrumors 6502

    Prototypical

    Joined:
    Apr 22, 2011
    Location:
    Nebraska
    #13
    Having the same problem here. Oddly, the app works perfectly if I wake up the ATV4 with the physical remote first. It even puts the ATV4 to sleep, but can't find it again once the device goes inactive.

    I had this problem constantly with my ATV3 and the old remote app, so I had hoped this combo would be better. It was... for awhile. I honestly think it's related to updating iOS; every time I push an update on my phone the connection between my two devices seems to fail.

    NYMinute - I'll try your suggestion and report back.
     
  14. sinatik macrumors member

    Joined:
    Jul 20, 2016
    Location:
    Virginia
    #14
    Had the same problem, wouldn't recognize apple tv with my new iphone 7+, pulled the plug on the apple tv and let it reset, worked first time after that.
     

Share This Page