Remote Connection Issue with Windows

Discussion in 'macOS' started by robjulo, Feb 19, 2012.

  1. robjulo macrumors 6502a

    Joined:
    Jul 16, 2010
    #1
    Having an issue connecting to my work computer (which is a windows computer) using RDC from my Mac.

    When logging on with my Mac, the RDC box comes up, with my work computers name, however, I get "The Mac cannot connect because the Windows-based computer cannot be found." I've tried adding the domain to the computer name to no avail.

    I have no issues connecting to the same work computer using my Windows 7 laptop.

    My place of work uses Windows Small Business Server 2011 Standard if that helps.

    Thanks for any help
     
  2. MacForScience macrumors 6502

    MacForScience

    Joined:
    Sep 7, 2010
    Location:
    USA
    #2
    Basic question: did you open the correct ports on your firewall on your mac? I assume if it works with the windows laptop your router has port forwarding enabled.
     
  3. robjulo, Feb 19, 2012
    Last edited: Feb 19, 2012

    robjulo thread starter macrumors 6502a

    Joined:
    Jul 16, 2010
    #3
    Thanks. I have not opened any ports on the firewall on the Mac, in fact the firewall is turned off. I should also mention that when I bring the Mac to work and use the work wireless network, I am able get connected and to use RDC to control my work computer.

    Also, I tested using my iPhone as a hotspot (thereby using the 3G as my network) and had the exact same results as I do at home, the Windows laptop is able to get on with no problem, the Mac laptop cannot find the computer.

    IT guy at work didn't have a clue. He thinks the Mac laptop somehow cannot figure out how to get to my computer and that it needed more information to resolve, but he didn't really have any solutions.
     
  4. jackrv macrumors 6502

    Joined:
    Jul 14, 2011
    #4
    Do your Windows laptops use a VPN? Are they set up by you or your PC guy? It seems that either your Mac is not connecting to your company network, or at least not getting an IP or using your DNS servers. We really need more info on your setup.

    Can you ping your work computer via the IP address? If yes, it sounds like a DNS issue. If no, it could be one of many issues.

    RDC from a Mac is the same as Windows. It is just a protocol. The problem is not RDC but connecting to the network correctly.
     
  5. robjulo thread starter macrumors 6502a

    Joined:
    Jul 16, 2010
    #5
    Thanks again. I'll try and explain the best I can.

    To access the work computer I type in via the browser remote.companyname.com

    That brings up a Windows Small Business Server 2011 logon screen. On the right it says "Remote Web Access" and allows me to log on. That works fine on the Mac.

    One I log on to that screen, I am then taken to a "Remote Web Access: Remote Workspace for myname" On the left side of the screen I can click "check email". In the middle of the screen I have the option to access shared folders. On the right side of the screen there is an option to "connect" and it has my work computers name.

    I have no problems accessing the email and shared folders as described above. it is when I click "connect" to actually access and control my computer remotely that trouble starts with the Mac.

    When I click "connect" on my windows laptop, another logon box comes up, I again input my username and pw and I can now control the work computer.

    When I click "connect" using the mac laptop a computername.rdp downloads. Doubleclicking that brings up the Remote Desktop Connection box. It is preloaded with my work computer name. However that is when I get the message that it cannot find the computer.

    Hope that helps explain it.

    Again, thanks.
     
  6. TracyS macrumors newbie

    Joined:
    Aug 30, 2012
    #6
    In case anyone else is having this problem, another thing to check is whether the home and work IP address ranges are the same. Windows computers don't have a problem with it. Macs do. If you change your home IP address range, you may be successful.
     
  7. gretch6364 macrumors newbie

    Joined:
    Apr 16, 2013
    #7
    Has anyone found an answer to this issue? I have the exact same issue. A PC can access the work connection easily..but no go on the Mac. I also tried through Firefox.

    Thanks!
     

Share This Page