Remote Desktop disconnection now that I am on Lion

Discussion in 'iMac' started by MissReena, Jan 25, 2012.

  1. MissReena, Jan 25, 2012
    Last edited: Jan 25, 2012

    MissReena macrumors newbie

    Jan 12, 2012
    I tried doing a search on this, but after reading the 20th forum post and not finding what I was looking for, I decided to just post my question and hope for the best.

    I work from home on an iMac and connect to a PC in my office that is running Windows XP Professional.

    Up until Saturday, I was using an iMac that was running OS X 10.6.8 and I connected via Cisco VPN and Remote Desktop with no issues. Everything connected well, and I rarely lost my connection, unless there as an issue with my actual internet connection.

    On Saturday, I got a new iMac (converted my husband by giving him my other one) and this one is running OS X 10.7.2. I used Time Machine to set this new computer up to mirror the one I was using.

    I noticed right away that I could no longer use the Cisco VPN, and instead had to set up a VPN through Network Preferences. This appears to be an issue with Cisco not updating to work with Lion, but was not a huge deal. I also have a MacBookPro that runs the VPN this way and have no real issues with it.

    Over the past two days, my remote desktop has been disconnecting on very frequent basis. I even uninstalled Remote Desktop and downloaded it again from Microsoft, to see if that would help, but no luck. If I Command + 2 and minimize the screen to do something on my Mac desktop, which I do a lot, there is a fairly good chance that when I go back to the remote desktop, it will be disconnected. And if I am away from my computer longer enough for the screen saver to kick in, both the VPN and the remote desktop will disconnect.

    I did not have these issues when I was on 10.6.8 and am wondering if there is some kind of workaround that will stop them from happening on 10.7.2

  2. GGJstudios macrumors Westmere


    May 16, 2008
    I use TeamViewer, which works with Windows, Mac OS X, Linux, Ubuntu, iPhone, iPad, etc. It's very secure and quite simple to set up and use (no messing around with ports), which comes in handy if providing remote support to those who aren't very computer literate. You can talk them through the setup on their end and be connected to them in less than a minute. It's also free for personal use. I prefer it over LogMeIn because it includes free file transfers between computers, a feature I use frequently.
  3. MissReena thread starter macrumors newbie

    Jan 12, 2012
    Hi GGJstudios

    I was hoping that someone could tell me why this was happening on Lion and if there were any fixes. I realize there is other software out there I can use (I have seen posts similar to this one from you in other threads), but I would like to stick with what I have, if possible.

    Most curious/confused over why this only started when I switched to the new iMac with Lion.
  4. LPZ macrumors 65816

    Jul 11, 2006
    Just some information, perhaps not relevant. I can remotely view/operate my Mac Pro (which is running 10.6.8) from my MacBook (which is running 10.7.2). The connection is via VNC, using the built in Apple vnc server and client. Before I can connect, I need to log in to my employer's VPN. This is done with the newly-released Cisco AnyConnect Client 3.0.5075, which seems to work fine under Lion.
  5. MissReena thread starter macrumors newbie

    Jan 12, 2012
    I VPN to the network as well. I did not realize Cisco had released a new client that would work with Lion. I just know the old one no longer works.

    I have tried VNC before, but it winds up being way to slow and jumpy on my work network. We use it internally, but only when we have to. Remote Desktop seems to have the least amount of lag, so I would like to be able to continue using that.
  6. danny_w macrumors 601

    Mar 8, 2005
    Austin, TX
    I have had many issues with Microsoft RDP but I cannot remember if they go worse after Lion or not. I usually use CoRD which is a direct replacement for RDP but outs everything into one window (much more Mac like). You might give this a try and see how you like it and if you still have the same issues. If you continue to have issues it may well be your VPN connection, esp. since you say that VPN usually disconnects if the screensaver kicks in.
  7. MissReena thread starter macrumors newbie

    Jan 12, 2012
    So just a bit of a follow up... if I minimize the remote desktop and do something on the Mac, even if the screen saver does not kick in, the RD disconnects after about 5 mins. I read something on another post about putting something under the mouse of the computer I am RDing into to trick it into thinking it is still active (like an analog watch), but that is not really an option for me.

    I am trying some of your suggestions about other software, but still wish the Remote Desktop would just work properly. I am used to all of the shortcuts and such that come with that one, and am not looking forward to re-learning all that stuff.

    Trying CoRD right now. Seems to be a bit slower than the Microsoft RD was, but that could just be because I am frustrated with this thing and just want it all to work the way it did before *LOL*. Plus, I go back and forth between this computer and my husband's computer upstairs, so I would like to be running the same familiar programs on both.

    Anyone else out there have these issues and manage to fix them? Or has Lion just killed my RD dreams?
  8. MissReena thread starter macrumors newbie

    Jan 12, 2012
    I tried CoRD, and had the same issues. After about 3 to 5 mins of inactivity, the RD seems to disconnect on its own... and it doesn't give me any kind of indication either.. I just go back to that window and everything is frozen...

    VPN connection was fine when I used Cicso on the previous OS, but on Lion, I can't use the same one I used before. Trying to find AnyConnect now to try it and see if that helps. I don't see any settings on the Mac VPN that would cause this, so I am getting stumped.
  9. kcassidy macrumors newbie

    Feb 13, 2008
    Just found this thread as I'm having the exact same problem and it even does it while I'm typing so it isn't mouse activity.

    Did you ever get a solution to this?

  10. Rudi9 macrumors newbie

    Nov 6, 2012
    RDC version?


    I am having the exact same issue and noticed today, by accident, that I am not running the latest RDC client. I don't know why the MS auto updater did not say anything but apparently, the latest greatest is version 2.1.1 vs 2.0.1 which I was running so far.

    Not sure if that will fix the problem as I have to see for myself but I wanted to mention it since the last view month were pretty frustrating when working from home.

  11. Rudi9 macrumors newbie

    Nov 6, 2012
    Well, no luck, just had another hang... has any one else fixed this issue so far?
  12. Adz76, Nov 6, 2012
    Last edited: Nov 6, 2012

    Adz76 macrumors member

    Mar 3, 2011
    Dagobah System


    I'm no expert although I do work in IT my thoughts are to make sure both machines are bang up to date regarding all software to start with.

    If that doesn't work I'd probably copy all the settings down and try to recreate the connection again from scratch which could give a good result.

    This page might help shed some info as it seems like you aren't alone, nearer the bottom there's a lot of Lion / ML discussion which points at Cisco not making a new 64 bit connector which Lion will need.

    Checking the " Open in 32 bit mode " of the connection might also be worth a try which can be accessed via right click \ get info.

    To be honest, I'd prepare for the worse and hope for the best and resign yourself to a different app. Team viewer is superb on any device I've used it on.

    Another Mac specific one we use for connecting to Virtual PCs is iTap which isn't free and has certain requirements which if supported by the network don't require any VPN.

    Good luck!
  13. donald.t macrumors newbie

    Nov 21, 2012
    Do one thing, disable "fast-switiching" option..i hope this can sort out your issue.
    If it does not cause any effect, then please let me inform.
  14. sverdlov1 macrumors newbie

    Dec 8, 2012

    I am having the same issue with RDP via VPN after moving to Lion.
    What is "fast switching" - i'd like to try this.
    Is it under SystemPref./Users&Groups ?
  15. donald.t macrumors newbie

    Nov 21, 2012
    Fast switching, uses the CPU and cache, a packet has been forwarded and information about how to reach the destination is stored in a fast-switching cache. This way, when another packet going to the same destination is seen, the next hop information can be re-used from the cache, so the processor doesn't have to look up and assemble all the information again. I think, it is a nice option.
  16. FFabian macrumors member


    Aug 26, 2010
    Bochum, Germany
    I had a problem connecting to my Uni with the inbuilt Cisco VPN. I solved it by disabling "Back to my Mac" in the iCloud-Settings of my iMac. It's worth a try...
  17. djmdorn, Feb 1, 2013
    Last edited: Feb 1, 2013

    djmdorn macrumors newbie

    Feb 1, 2013
    OS Lion; Cisco VPN Problems

    I have also been exasperated by the loss of my VPN connection since upgrading to Lion. It is absolutely mind boggling that hackers can invade our SC DOR website and steal SSN and bank account data; yet NO ONE can figure out how to fix the compatibility of OS Lion and Cisco VPN with Microsoft RDP... I just don't get it..!!!!!!

Share This Page