Remote (iOS), Home Sharing, and Wi-Fi Syncing Problems

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Zerthis, Aug 3, 2013.

  1. Zerthis, Aug 3, 2013
    Last edited: Aug 3, 2013

    Zerthis macrumors newbie

    Joined:
    Jul 28, 2013
    #1
    Hi.

    I've got 3 devices running of which all are logged into the same Apple ID:
    - iPhone 4S (6.1.3)
    - iPad 4th gen (6.1.3)
    - MacBook Pro 13-inch, mid 2012 (10.8.4)

    Everything is connected through my ZTE Wi-Fi router (got it from my ISP) and they are on the same (W)LAN network: xxx.xxx.1.1 (router) - xxx.xxx.1.2 (MacBook Pro) etc. All connected through Wi-Fi, although I have tried everything below with the MacBook connected directly via ethernet as well. I'm running Network Radar on my MacBook and it is able to see and list all those devices connected to my network. So my setup seems to be running well.

    But, the problem is, although the devices can see each other it is not working at all. The iPhone and iPad show up in iTunes for Wi-Fi syncing, which fails because the selected device can never be found, the Remote app says I have to enable Home Sharing on my MacBook, and in the Music and Videos app (on the iPad and iPhone) the shared button might show up, but fail to load anything when selected.

    So yeah, I've tried a whole bunch of things:
    - disabling/enabling the firewall on both my MacBook as well the one in the router
    - opening ports as suggested by Apple (TCP 123, 3638 and UDP 123, 5353)
    - signing out and in with this same Apple ID on all the devices
    - restarting all the devices, including the router
    - changing channels of the Wi-Fi
    - changing SSID, passwords and encryption types for Wi-Fi on my router (just in case)
    - added DHCP reservation so all (W)LAN IPs are static (thus my MacBook will always be xxx.xxx.1.2, iPhone xxx.xxx.1.3 etc.)
    - toggling some other unrelated settings of which I do not know its specific function on my router, which were suggested in the many related threads on this forum and things I have found on Google
    - (re)installing the latest version of iTunes (11.0.4) after deleting all files of the old installation
    - deauthorizing and authorizing my MacBook etc.
    - changing the wireless mode from 802.11b/g/n to all possible alternatives

    ...and that is where it got interesting. After changing this setting to 802.11g the iOS Remote app, which is available in the App Store, is working flawless (even after a reboot of all devices).

    Yes, I can control iTunes on my MacBook without any problems from my iPad and iPhone, although: Home Sharing is still not working on both devices, while configured correctly (I assume, because Remote is working), and iTunes seems now unable to recognize both iOS devices for Wi-Fi syncing - iTunes is not even listing them anymore.

    Switching 802.11g back to 802.11b/g/n and the Remote app stops working, and the situation is exactly as it was before. No Remote and Home Sharing, iOS devices show up in iTunes but fail to sync. Switch it back to 802.11g, and the Remote app works flawless again, but no Home Sharing and Wi-Fi sync.

    To be even more specific, 1 out of 10 times the Shared button might show up on one of my iOS devices (never both at the same time) and Home Sharing works, until the device disconnects from the network. This is not reproducible at all, it is completely random.

    I know I could solve this problem by purchasing an AirPort Express, but since it is almost working, I'd like to solve the problem. I was planning on purchasing an Apple TV, and I figured this configuration must work before I could use it without any headaches.

    Anyone any idea where my configuration needs to be changed?

    Btw, syncing the iPhone and iPad connected via USB is just working and yes I selected Wi-Fi syncing in the settings.

    Edit: I use the app TinyScan on my iPhone which let me connect via Wi-Fi (xxx.xxx.1.3:10000) to download the scanned files, and this works in any scenario.
     
  2. Zerthis, Aug 4, 2013
    Last edited: Aug 4, 2013

    Zerthis thread starter macrumors newbie

    Joined:
    Jul 28, 2013
    #2
    OK, little update since I continued troubleshooting after posting here.

    After switching back to 802.11b/g/n and disabling "IGMP Proxy" in my router, things seems to be working a lot better now. "IGMP Proxy" is enabled by default.

    Remote does work on both the iPad and the iPhone and my iTunes library is shared and I can now access the library and play/stream music and videos. Also from my GF's iPhone, which uses another ID in the store, Home Sharing does work properly with my ID. No problems here anymore.

    However, while my iPad and iPhone do show up in the iTunes sidebar (while unplugged), Wi-Fi sync still gives the same error (the device can not be found) - strange thing is, it did sync successfully the first time connecting after disabling "IGMP Proxy". Whatever I do now, they won't sync anymore (reboot, reinstall iTunes, reset settings, reset phones etc.). For now I'll let them sit in the sidebar and whenever I feel the need to sync I'll plug in a cable.

    So in the end, 2 out of 3 problems seem to be resolved.

    Edit: it seems after the iPhone or iPad auto-locks I have to close all applications (on all devices) and open them again to get it working. So if I'm playing a song on iTunes on my MacBook, which I selected with the Remote app on my iPhone, and I leave the iPhone on the table for 10 minutes (Auto-Lock is set to 2 minutes), I have to restart everything to get it working again. Why has this got to be so hard?
     
  3. Zerthis thread starter macrumors newbie

    Joined:
    Jul 28, 2013
    #3
    Couple of days now using this configuration and all seems fine.

    Remote and Home Sharing work without any problems now. Wi-Fi Sync works automatically, but not if I want to sync manually. I can live with that, probably an issue with any of the security settings on either my Mac or the router.
     

Share This Page