Remote server connection slows entire computer?

Discussion in 'macOS' started by FoxyKaye, May 16, 2007.

  1. FoxyKaye macrumors 68000

    FoxyKaye

    Joined:
    Jan 23, 2004
    Location:
    San Francisco, Terre d'Ange, Bas Lag, Gallifrey
    #1
    This is a stumper for me - here's the situation:

    Our organization runs a national VPN between Oakland, Chicago and NYC. The primary server (documents archives, backups, etc.) is here in Oakland, and it is an older G4 1GHz XServe running Panther Server (10.3.9). The Oakland and NYC offices each have T1 lines.

    One of our users in NYC, when she connects to the server from NYC (using the "Go" menu and its IP address), says that while connected to the server, her entire computer slows down. She's using a MacBook C2D (10.4.9), the mid-range model from immediately before yesterday's lineup refresh. After unmounting the remote connection, everything speeds up again for her.

    I asked her if the sluggishness was limited to the apps she was using to open and browse documents on the server (which might make sense b/c of the lag on the T1 and VPN), but she claims that everything is slowed down (Mail.app, other applications such as FireFox, etc.).

    The only thing I can think of is that Finder is trying to index the remote hard drive when it is mounted on her desktop. I know when you first install OS X, it is actually a little sluggish b/c it is indexing the hard drive for the first time. Her MacBook isn't that old, but she only connects to the Oakland server once in a while. If it is trying to index the remote hard drive, is there any way to turn off indexing for remotely mounted devices?

    Any ideas on what's going on?
     
  2. kostia macrumors regular

    Joined:
    Apr 14, 2007
    #2
    I'm not sure what would make her whole system slow down, but it's possible that her VPN connection is set to route all Internet traffic over the VPN, and that would make it feel like the whole system was slower.

    Have her run Internet Connect and click on the lock icon for the VPN. Then select "Options" from the "Connect" menu and uncheck "Send all traffic over VPN connection."

    This happened to me when I first set up my VPN connection, so I suspect it may be enabled by default.

    This page on macosxhints.com refers to the same thing.
    http://www.macosxhints.com/article.php?story=20050501025619186
     
  3. kostia macrumors regular

    Joined:
    Apr 14, 2007
    #3
    As to your other question, I don't think it's Spotlight. An easy way to check is to just look at the Spotlight icon in the upper right: when it's indexing, it has a dot in the center of the magnifying glass.

    I also just tried to add my (VPN-mounted) server to the "Privacy" tab in the Spotlight preference pane, and it wouldn't take it. I couldn't browse to it and add it, and I couldn't drag it in. It just ignored it. This says to me that Spotlight doesn't even try to index network drives.
     

Share This Page