Remote Shutter Differences between XTi & T1i

Discussion in 'Digital Photography' started by qCzar, Apr 20, 2011.

  1. qCzar macrumors regular

    Joined:
    Feb 27, 2011
    Location:
    SFBA, CA
    #1
    Does anyone know of the differences between the Canon XTi and the T1i? I had a XTi prior and had purchased a remote shutter release for the 40D and 50D but was able to purchase a 2.5mm male-to-male cable with success to my Canon XTi. I sold the XTi a few months back and bought the T1i even farther back but I never used the remote on the T1i. Now, I need to but can't get the camera to recognize the remote. The remote and cable are both the same, so I'm assuming the way the T1i reads the signal input has changed.

    Does anyone have any suggestions as to how I can get this to work? I'd rather not spend the money for a new shutter release but if it comes down to the point I must, well, then I must.
     
  2. Designer Dale macrumors 68040

    Designer Dale

    Joined:
    Mar 25, 2009
    Location:
    Folding space
    #2
    There are reviews of both cameras on DPReview. The link is listed below this post. The XSi is the 400D and the T1i is the 500D. both use E-3 Type wired remote. The 40D, which the remote was designed for, uses an N3 Type wired remote (I don't know what that means). Vivitar makes a version of the remote in your link specifically for the Rebel cameras. The firmware on the 500D is user upgradable. You might want to look into that. I do know that the pin-outs on the jacks are different. Maybe the newer camera doesn't read the input the same. In which case you need a new remote.

    Canon 500D on DPReview

    More Than You Want to Know About Camera Jacks

    Dale
     
  3. qCzar thread starter macrumors regular

    Joined:
    Feb 27, 2011
    Location:
    SFBA, CA
    #3
    Thanks Dale!

    I thought the XTi was the 400D and the XSi was the 450? Either way, both cameras (as well as the 500/T1i) have a 2.5mm plug. The 40 & 50D use an odd tri-plug. The Remote I purchased came with the plug for the 40 & 50D (obviously) but I was able to buy a 2.5mm male-to-male hoping it'd work on the XTi, it did.

    I'm just confused how another EOS Rebel won't accept the remote. It could possibly be that I had CHDK Firmware on my XTi. I'll look around for user firmwares, and check out the links you provided.

    Appreciated!
     
  4. Designer Dale macrumors 68040

    Designer Dale

    Joined:
    Mar 25, 2009
    Location:
    Folding space
    #4
    I have the XSi. It's also known as the 450D/KISS2.

    Your newer camera probably has updated software in it that constrains it to that micro jack thing and won't read a signal from the 40/50D style jack even with that male-male connector.

    Good luck.

    Dale
     

Share This Page