Remove all local contacts

Discussion in 'iPhone' started by Maury, Nov 5, 2014.

  1. Maury macrumors 6502

    Joined:
    Mar 25, 2008
    #1
    My contacts list on the iPhone was out of control, there were hundreds of old contacts in there from places I used to work.

    Deleting them on the iPhone is a huge PITA, so I got "smart" and did so in the Contacts app on my Mac, which gets its list from iCloud.

    However, they're all still on the phone. I assume this is because they are local copies, not iCloud ones.

    Is there a way to delete all the local contacts and re-sync to iCloud?
     
  2. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #2
    In iTunes turn off Contacts in your Info tab and sync. If all else fails restore, set up as a new device, and don't sync any Info data over.

    Did you move all your contacts to iCloud on your Mac?
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    On the phone in the iCloud settings turn contacts sync off and you should get a prompt asking if you want to remove contacts from the phone. Say yes. Then turn contacts sync back on and it should push out what is in iCloud.
     
  4. Maury thread starter macrumors 6502

    Joined:
    Mar 25, 2008
    #4
    Unfortunately, this only deletes the ones it originally got from iCloud, not the ones I got from old email accounts and such, which is the majority.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
  6. Maury thread starter macrumors 6502

    Joined:
    Mar 25, 2008
    #6
    Most excellent hunting!

    Sadly, I had somehow turned iCloud sync back on before running this. It happily deleted everything off iCloud too.

    Trying to fix that now...
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Dang! You are just having no luck at all with this. :eek:
     

Share This Page