Remove number from iMessage help?

Discussion in 'iOS 5 and earlier' started by iMrNiceGuy0023, Oct 21, 2011.

  1. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #1
    So I put my sim card in my friends phone iPhone 4 running on iOS 5 to test something, now under his settings > Messages my number is in gray and there is no way to edit or delete my number.

    All my iMessages now go to his phone when he cuts on the wifi.

    Is there a way to delete my number

    The iMessage is being sent to my number, so how is his phone,(with no sim card) getting it?
     
  2. dotme, Oct 21, 2011
    Last edited: Oct 21, 2011

    dotme macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #2
    From similar threads, this would appear to be a bug. I can't imagine Apple did that by design. Options? Wipe the phone is probably the best bet, and set up again as new or restore from prior backup.

    Edit: Another option might be to disable, and re-enable iMessage on the phone. This might do the trick assuming you have access to the phone or a cooperative friend.
     
  3. ShiyAlpha macrumors newbie

    Joined:
    Nov 19, 2011
    #3
    I have exactly the same problem, have you found a solution to fix that, iMrNiceGuy0023? Would be nice.
     
  4. braaains macrumors newbie

    Joined:
    Aug 31, 2011
    #4
    Not 100% certain, but I think if your friend goes to iMessage settings, then turns iMessage off and on again (give it a few seconds in between), it'll reactivate and only have the number for the SIM which is currently in the phone.
     

Share This Page