iPhone Remove tweak completely?

Discussion in 'Jailbreaks and iOS Hacks' started by BullittMustang, Jan 14, 2014.

  1. BullittMustang macrumors 6502a

    Joined:
    Mar 27, 2008
    #1
    I installed ccpinfo for control center. It moved the position of the hidden settings 7 to right on top of the airplay button. I've uninstalled both tweaks but when I reinstall hidden settings it remembers all the last settings. Is there any way to completely remove all files of a tweak?
    Thanks
     
  2. seanwebb68 macrumors 6502

    Joined:
    Jul 27, 2010
    #2
    You will need to find the .plist file that is related to this tweak and remove that this will remove any config settings
     
  3. BullittMustang thread starter macrumors 6502a

    Joined:
    Mar 27, 2008
    #3
    Thanks. Any idea of where it would be?
     
  4. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #4
    Custom settings are saved in the plist.
    Usually the plist remains on your device even if the tweak was removed.
    Just check for the tweak related plist and delete manually.

    ----------

    var/mobile/Library/Preferences
     
  5. seanwebb68 macrumors 6502

    Joined:
    Jul 27, 2010
    #5
    Check /var/mobile/library/preferences

    then look for the tweak name.. hopefully it will be there.
     
  6. ~Ks383~ macrumors 6502

    Joined:
    Jul 6, 2011
    #6

    Icleaner pro will enable you to easily find and delete left over plists from deleted tweaks. You have to add a repo to download it (http://exile90software.com/cydia/).
     
  7. Guitarplaya4JC macrumors newbie

    Joined:
    Apr 8, 2008
    #7
    I found it!!

    I found it! For those of you out there running into the bootloop (or safe mode) issue after installing ccpinfo for Control Center, I figured out how to fix it. YMMV, but this worked for me and meant I didn't have to spend hours setting up my phone again after a restore and rejailbreak!

    tl;dr:
    1. SSH or ifunbox or something into your iphone files.
    2. Browse to /var/mobile/library/preferences
    3. Delete de.j-gessner.ccloader.plist

    As I said, YMMV, but it worked for me! Hope it helps others!!
     
  8. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #8
    Why not just enter Substrate Safe Mode by pressing volume up at the Apple logo, then uninstall the tweak through Cydia?
     
  9. Guitarplaya4JC macrumors newbie

    Joined:
    Apr 8, 2008
    #9
    I couldn't get into safe mode. Even the volume up trick didn't work, just kept rebooting. If safe mode works for you, by all means, do that, but in my case I couldn't get into safe mode which is why I resorted to finding the plist and deleting it manually via ssh.
     
  10. BullittMustang thread starter macrumors 6502a

    Joined:
    Mar 27, 2008
    #10
    Thanks!
    And idea how to find ccpinfo? Can't find it in the plist files. Probably called something weird
     
  11. BumpyFlatline, Jan 16, 2014
    Last edited: Jan 16, 2014

    BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #11
    Sometimes the file name has the developers name instead of the package name. Maybe look for that?

    Edit: Oh yea, also, sometimes there's not a plist in that caches folder but instead there will be an actual folder. Then inside that folder you'll see a few db cache files for the package you're trying to clean up. I usually delete the tweak folder inside that var>mobile>library>caches directory. For example, Barrel creates a folder called aaronash.barrel.settings or something like that. Since I removed barrel and no longer use it, I deleted this folder for the above directory.

    Hope this helps. Let me know if you have any questions.

    Edit: Don't forget to empty the trash can if using iFile and you have that feature turned on in its settings.
     
  12. BullittMustang thread starter macrumors 6502a

    Joined:
    Mar 27, 2008
    #12
    Thanks, can't find it. Maybe it's gone. The spring board settings button went back to normal after I removed cc loader.
     
  13. ttinc macrumors regular

    Joined:
    Sep 12, 2013
    #13
    I'm having the same issue...was up for hours last night trying to fully delete any traces of CCQuick as it's overriding CCToggles even though I've deleted CCQuick and tried do delete all traces of it through iFile and iCleaner as well.
     

Share This Page