Remove word from iPhone Auto-Correct Dictionary?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by GimmeSlack12, Jan 9, 2010.

  1. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #1
    So at one time or another I typed "tge" instead of "the" but I hit the little X when the iPhone suggested "the" (accident) and now the iPhone recognizes "tge" as a word and never corrects it.

    Where is the iPhone User Dictionary so I can remove the word "tge"? I've searched and searched but there isn't much out there.
     
  2. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #2
    It's under SETTINGS. And you want to look for "Reset iPhone Keyboard/Dictionary".

    I don't know where exactly this is in the Settings menu but I'm sure someone will chime in for further info.
     
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    Settings>General>Reset>Reset Keyboard Dictionary.
     
  4. Mr. Gates macrumors 68020

    Mr. Gates

    Joined:
    Jun 17, 2009
    Location:
    --Redmond --------- ----------------Washington---
    #5
    Only problem with that reset is that you also have to re-train it to allow words like $#!T and ,,,,, you know:rolleyes:
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #6
    Yeah, the Dictionary sucks.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  7. ICU-RN macrumors newbie

    Joined:
    Nov 27, 2011
    #8
    Thanks for helping out with resetting my iPhone auto correct dictionary. I accidentally typed "thSt" for "that" and it was driving me crazy. I kept searching for a way to fix it and when I saw the "reset" option under general, I was terrified to click on it since I didn't want to take the chance that my entire phone would be reset!! ;)
     
  8. emon878 macrumors member

    Joined:
    Apr 11, 2010
    Location:
    Canada
    #9
    You can also do the reverse of what you did to add it to the dictionary example

    Typing yoo autocorrects it to "too" if you press the x then it adds yoo to the dictionary

    Now to remove it type "too" and it will try to autocorrect to "yoo" now press the x and yoo is removed.

    Now typing yoo will autocorrect back to "too"
     
  9. Mcnoobers macrumors newbie

    Joined:
    Apr 26, 2012
    #10
    I was messing around one day and found out if you hold down a key it pops up with different ways to type that letter. I types you in a different way and now when I type "tou" instead of doing "you" it does "ÿóü" and i don't know how to get rid of it.
     
  10. The Franker macrumors newbie

    Joined:
    May 6, 2012
    #11
    My iPhone continues to correct my name to another word, but only when it's the first word on a line. Needless to say this happens constantly. I keep pressing the x button in the suggestion popup but it continues. I already reset the keyboard but to no avail! Any suggestions?
     
  11. pb4ugotobed macrumors newbie

    Joined:
    May 11, 2012
    #12
    I ran into the same problem.

    It is a work-around, but will fix it without having to completely reset your dictionary and relearn all of the words you normally use.

    go to Settings >>> General >>> Keyboard >>> and look at the shortcuts if you scroll down. Click on Add new shortcut. Type the CORRECT word in the Phrase box, and type your misspelled word in the Shortcut box.

    Whammo, fixed. I've been typing ypu instead of you for months now until I figured this out. And it saves all of the other words it's learned for work (like car names, trim levels, products we use, etc).
     
  12. Ladydiggity macrumors newbie

    Joined:
    Nov 2, 2012
    #13
    Really??? It's SUPER easy.... Go to your settings>general... Scroll all the way to the bottom to RESET> reset keyboard dictionary. Done deal peeps. Btw, it'll erase all words you've added. So for an easier step to better "auto-correct".... Start typing and adding the words you want back on... Ex: swear words, or Canadian spelling! Good luck!
     
  13. Nightowl4272 macrumors newbie

    Joined:
    Feb 13, 2011
    #14
    My friend that's not a workaround, that's the bloody fricken answer!!!! At least to my problem anyway. Thank you thank you thank you!!!

    Btw, before applying your fix, my gratitude above would've read, "Thank yku thank yku thank yku!!!" ;)
     
  14. Lhennis macrumors newbie

    Lhennis

    Joined:
    Dec 9, 2015
    #15
     
  15. Lhennis macrumors newbie

    Lhennis

    Joined:
    Dec 9, 2015
    #16
    Mine is under General>>Keyboard >>Text Replacement
     
  16. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #17
    It has been renamed a bit since introduction some years ago.
     
  17. Rachelswanson macrumors newbie

    Rachelswanson

    Joined:
    Jan 29, 2016
    #18
    Go to settings
    General
    Reset
    Reset keyboard dictionary
     
  18. juliestarchild macrumors newbie

    Joined:
    May 27, 2008
    #19
    --- Post Merged, Nov 14, 2017 ---
    Thanks - that fixed it without deleting everything else it'd learnt - you star!
     
  19. savvycomdev macrumors newbie

    savvycomdev

    Joined:
    Nov 15, 2017
    Location:
    MMO
    #20
    Thanks ,i have same problems. Now thanks you guide, help me fix it.
     
  20. sparker781 macrumors newbie

    Joined:
    Feb 14, 2015
    #21
    I've checked the stuff you've said however when I go into Text Prediction there is nothing there. There is a word A L O t that I want to get rid of....I can't even type the word here....It's not showing up. I guess I'll have to do the whole reset thing.
     

Share This Page