REMOVED

sluggozmom

macrumors 6502
Sep 13, 2011
271
18
Massachusetts
Have your carrier put a block on text messages.
I'm with AT&T... I've had them blocked for as long as I can remember. iMessage is all I need.
Yesterday I got a text, not an iMessage :eek:
Somehow when I switched to my new phone, the block disappeared ..
I called AT&T and had it put right back on.
I'm sure any carrier will block it for you
 

Tyga

macrumors newbie
Oct 2, 2012
21
0
Settings->Messages->Send as SMS - Turn that Off.

Edit: Or, you could try cutting off MMS Messaging in the same pane. You can see if that cuts off MMS for SMS-only or both SMS and iMessage.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.