Removing the "Other..." Option on the Login Screen on SL

Discussion in 'macOS' started by OverSpun, Jan 29, 2011.

  1. OverSpun macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #1
    I took my laptop to the genius desk last year, and I still haven't bothered fixing this little issue because I never had the "Other.." option when I turn on my MBP?

    I called the store fixing this issue since they caused it during my visit there. I really don't want to drive to to apple fixing this. I'm sure its a simple issue, but its annoying having it on there. Of course, I don't have a screenshot before logging on.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    So what is this Other thing? A user? If it's a user, just remove that user from System Preferences > Users
     
  3. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #3
    Go to System Preferences/Accounts and delete the "Other" account.
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    Have you taken a look at System Preferences > Accounts >> Login Options >>> Display login window as: ? Is "List of users" or "Name and password" selected?
     
  5. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #5
    That's probably there because the root account has been enabled. You can use Directory Utility to disable it (if you're in Snow Leopard, it's in /System/Library/CoreServices, in Leopard it's in /Applications/Utilities). Make sure the lock in the lower left is unlocked (if not, click it and enter your password), then go to Edit -> Disable Root User.

    jW
     
  6. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #6
    Thank you, I appreciate the post. I am on Snow Leopard, but I can't find the CoreServices in Finder, unless I'm looking in the wrong area-

    This is what I'm seeing when I turn on my MBP:
    [​IMG]
    [​IMG]
     
  7. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #7
    I actually, dont have a "Other" account on the left pane, but It seems like a different thing. I only have 1 single Admin on my laptop, since I"m the only person that uses this.

    All I see is, "Other Accounts" but theres only 'Guest Account'. I turned it off, and on and other things to try it to see if it changes anything, but its all the same.

    Thanks, I took a few screenshots to make this easier-


    [​IMG]
    [​IMG]
    [​IMG]
     
  8. tomllama macrumors regular

    Joined:
    Jan 7, 2007
    Location:
    CA
    #8
    That "Other" is the root account (same as my MP screen). If you simply go the the Mac help on your computer and search for 'disable root account' you should see what you have to do.
     
  9. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #9
    I can't seem to find it in the help. =/
     
  10. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #10
    1. Navigate to /System/Library/CoreServices (go to Macintosh HD and click through from there)

    2. Run Directory Utility.app

    3. Authenticate (click the lock)

    4. Click Edit in the Menu Bar

    5. Click "Disable Root User"

    If you don't see "Disable Root User" but instead "Enable Root User" report back.
     
  11. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #11

    IT WORKED PERFECT!!!! THANK YOU! This was bothering me since nearly a year now. :D
     
  12. tomllama macrumors regular

    Joined:
    Jan 7, 2007
    Location:
    CA
    #12
    For the future: To get to "Help" simply click on Finder and at the right side of the menu bar at the top of the screen it says "Help". You click that and then click Mac Help. It's amazing how much is in there and how much faster it can be than going back and forth here. :)
     
  13. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #13
    Sweet! Thank you, good sir! :)
     
  14. heffeque macrumors regular

    heffeque

    #14
    Where? What? I think they changed it on 10.6.7 because I can't find that here:

    [​IMG]

    I tried disabling Active Directory and LDAPv3. The "other" login is still there :-\

    Any other ideas?
     
  15. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #15
    Go at the top under "edit" and at the bottom, it should disable it. I'm on 10.6.7, and you're just missing it in directory utility.
     
  16. heffeque macrumors regular

    heffeque

    #16
    At the top I see Services and Search Policy, I don't see "Edit". The only "edit" button I see is the pencil, but it only edits "Active Directory" or "LADPv3". There's nothing about disabling root account.
     
  17. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #17
    This is what mine looks like-

    Double check with the steps someone else posted above, and perhaps you forgot something, but we're on the same version, and it is definitely possible. Afterwards, restart your machine, and it should be gone.

    [​IMG]
     

    Attached Files:

  18. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #18
    Just saw this thread. If you have a network account server (such as LDAP) you always get the "Other..." selection which lets you log into network accounts that haven't been established on your system.
     
  19. heffeque macrumors regular

    heffeque

    #19
    Yours doesn't have an Edit button either. There's the pencil to edit Active Directory or LADPv3, but nothing about disabling root (that's what I'm looking for).

    Not useful at all. Nobody is asking about LDAP servers.
     
  20. Mactasia, Jun 11, 2011
    Last edited: Jun 11, 2011

    Mactasia macrumors member

    Mactasia

    Joined:
    Jun 10, 2011
    Location:
    UK
    #20
    Um, 'Edit' doesn't appear in the window that opens. 'Edit' is in the menu bar at the very top of the screen. With Directory Utility open 'Disable Root User' will become available in the 'edit' menu if it is indeed enabled.

    See image below. Mine says 'Enable' instead of 'Disable' because my root account isn't enabled ;)

    [​IMG]
     
  21. heffeque macrumors regular

    heffeque

    #21
    Man! That doesn't look like an Apple approach GUI (putting it up there in the OS's menu bar).

    Thanks for everything. If it weren't for the screen I would have thought that it was in the window's menu bar (where "Services" and "Search policy" are) instead of in the OS's menu bar and that there was something wrong with my GUI.

    Thanks again!
     
  22. Mactasia macrumors member

    Mactasia

    Joined:
    Jun 10, 2011
    Location:
    UK
    #22
    No worries. Pleased to help! ;)
     
  23. malikkannan09 macrumors newbie

    Joined:
    Aug 16, 2012
    Location:
    Chandigarh, India
    #23
    Cheerz!! ... this root user was killing me.. thanx a ton! :D
     
  24. Hanlee macrumors newbie

    Joined:
    Apr 10, 2013
    #24
    I got the same issue,but it is special for me that although both I never join the network sever and disable my root Account,I still have the "Other...":(:(:(:(
     
  25. Hanlee macrumors newbie

    Joined:
    Apr 10, 2013
    #25
    Removing the "Other..." user on the Login screen on Mountain Lion.

    1.I did not connect the network serve or let anyone to remote control my computer.
    2.I disabled the "Root User".
    But the "Other..." User still here,what can I work for it?
    :(:(:(:(:(:(:(:(
     

Share This Page