Removing vibration sound for Mail push

Discussion in 'iOS 5 and earlier' started by Rofl, Oct 17, 2011.

  1. Rofl macrumors member

    Joined:
    Sep 7, 2010
    #1
    Has anyone noticed that when you have Mail pushed, you can't turn off the vibration sound?

    I usually like to keep my phone on silent but with the vibrate function on. However, since I have a lot of mail which gets pushed through, I tried turning off the vibrate function for the mail under notifications but there's no option to remove it! So I tried turning vibrate function off altogether under settings while the phone is on silent, but the mail being pushed through is still making a vibrate sound.

    Any solutions around this, or was there an oversight by Apple?
     
  2. Rofl thread starter macrumors member

    Joined:
    Sep 7, 2010
  3. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #3
    The only way to do that is to go into SOUNDS and pick "None" as the sound for Mail. That way, when you switch your iPhone to Silent, it won't vibrate.

    (Anything that has a sound alert will vibrate in Silent mode)
     
  4. scousers macrumors member

    Joined:
    Oct 14, 2011
    #4
    I find that i have it set to push every 15 mins, but it makes some swoosh sound if there is no mail. Is there a way to turn these off??

    EDIT: I mean fetch.... if i leave it on push for Gmail, will mew emails automatically appear in notifications?
     
  5. Rofl thread starter macrumors member

    Joined:
    Sep 7, 2010
    #5
    Ah I see, thanks. But it's quite inconvenient because if I have my phone on ring, then I like to hear the mail sounds, and ideally, I just want to remove the vibration sound specifically for mail. I just wished Apple would give us customisation for that.

    ----------

    Depends whether your Gmail allows push or not and whether you have enabled notifications for mail. If you've configured it via Microsoft Exchange instead of via the default Gmail setting, and notification for mail is enabled in notification centre, then enabling push will push the new mails from Gmail and you will receive notifications.
     
  6. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #6
    I would too. Here's hoping that iOS 6 brings that.
     
  7. escogido macrumors member

    Joined:
    Jun 10, 2011
    #7
    I totally agree with you. iOS 4 had that option, where you can keep the sound alert, but turn off the vibration for the mail fetch. So when I put my phone in the cradle overnight (on my night table next to my head) I just put it on silent and wouldn't hear the sounds, and then for the day I would take it off silent and have sounds come through when mail comes in. But it seems iOS 5 had neglected to keep this option... :mad:
     
  8. DCortez macrumors newbie

    Joined:
    May 30, 2012
    #8
    Still can't stop vibrate on email arrival

    I have tried everything suggested.
    under settings sound I have vibrate on. So my phone vibrates when a call comes in.
    Under settings sound ringer/alerts I have vibration off.
    Under settings sound ringer/alerts .. new mail I have "none" checked.
    Under settings mail/contacts/Fetch New Data I have Push OFF and fetch every 15 min. (If I don't do this I won't get email to my phone).
    Under the Fetch/Advanced .. I have all my email accounts set to FETCH not Push.

    My phone still vibrates when email arrives.
    When I first acquired my IPhone 5S this did not happen. Something has changed and I can't figure it out. Any suggestions?
     
  9. DCortez macrumors newbie

    Joined:
    May 30, 2012
    #10
    Stopped Vibration on Email arrival

    I think I fixed this problem. Could find nothing that worked so did a trial and error of various settings. My goal is to have my IPhone 4S vibrate when a call comes in ONLY. I could not stop it vibrating when email comes in .. but now I got it. Here is what I did:
    Sounds: at the top turn Vibration ON
    The next option below: Turn Vibration OFF. (not sure why there are two but just do it!)
    Under NEW MAIL: alerts NONE
    exit out of the Sounds and go to MAIL

    Set PUSH to OFF
    Under Fetch I chose every 15 min.

    Now my phone vibrates when a call comes in, no vibration when email comes in, and my email comes in every 15 min or when I turn on my phone and click on my mail boxes.
     

Share This Page