Renaming box disappears on Desktop 2.

Discussion in 'Mac OS X Lion (10.7)' started by Eradik, Sep 30, 2011.

  1. Eradik macrumors regular

    Joined:
    Jul 10, 2011
    Location:
    Pacific Northwest
    #1
    Ok, weird problem here.

    When renaming things on your desktop, I click on it and then hit enter. On desktop 1, this pops up and allows me to rename it:

    [​IMG]

    Now whenever I am on Desktop 2 or beyond, it goes like this:

    [​IMG]

    I can still rename it, but I have to go by memory on where my cursor is.

    I've rebooted, ran Onyx, etc etc. Any ideas what this is??
     
  2. Eradik thread starter macrumors regular

    Joined:
    Jul 10, 2011
    Location:
    Pacific Northwest
    #2
    I seem to have narrowed it down a little bit. Could someone please test this to see if it works on their machine or not?

    1) Open a Finder window. All my Files, for example. Make sure no other finder windows are open.

    2) Create a new desktop. Switch to that desktop. Check for rename bug.

    3) If bug exists, move finder window over to the new desktop and check again.

    In my tests, the desktop with the finder window does not have the rename bug.

    Can someone try for me please? I really just want to know if it's Lion or if I should try a format and reinstall
     
  3. leelance macrumors newbie

    Joined:
    Jan 11, 2012
    #3
    Results Confirmed

    This was driving me batty. Your information just (sort of) solved it for me. You're right... you can ONLY see the filename you are editing when you're on the desktop to which Finder is assigned. I thought it was just sometimes working and sometimes not, but now that you've pointed this out, I see consistent behavior all the time. Funky bug that should be fixed... but at least now I know how to not have to blindly rename files on my desktop. Switching to the Finder-associated desktop let's me see what I'm typing.

    Thanks. Definitely post back if you see a fix somewhere/somehow.
     
  4. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #4
    I just tried this and everything works normally for me no matter the desktop and has since I loaded Lion now that I thing about it. I have never had to result to the work around. Wonder if there is an intermittent bug?
     

Share This Page