Renaming of file extensions in Textedit

Discussion in 'OS X Mavericks (10.9)' started by thecork, Oct 1, 2013.

  1. thecork macrumors newbie

    Joined:
    Jul 25, 2012
    #1
    Previously, in Mountain Lion, i would be able to rename a file extension in textedit by clicking the filename at the top and typing in what i needed (i normally need to rename a downloaded .txt to .xml). In mavericks, no matter what i try, when i try and rename it to .xml, it just appends .txt automatically back to it!! Anyone else confirm this behaviour? Cheers.
     
  2. drew627 macrumors regular

    Joined:
    Jun 26, 2013
    #2
    Yeah that is the intended "smart" behavior. You can still use the Get Info panel though to change extensions though.
     
  3. thecork thread starter macrumors newbie

    Joined:
    Jul 25, 2012
    #3
    The problem is I don't want the smart behavior! I can easily change the extension in file manager but that's not the point. Annoyingly the only reason I actually have to rename it in the first place as it's a downloaded XML in Safari and that renames it to txt trying to be 'smart'! Guess I'll have to get hold of an app that will allow me to change the extension and dump TextEdit...
     
  4. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
  5. thecork thread starter macrumors newbie

    Joined:
    Jul 25, 2012
    #5
    Cheers I'll check them out..while I'm at it, not mavericks related I know but anyway of stopping safari renaming it when it downloads in the first place?
     
  6. w0lf, Oct 1, 2013
    Last edited: Oct 1, 2013

    w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #6
    You can make a work around for TextEdit:

    1) System Preferences > Keyboards > Shortcuts > App Shortcuts
    2) Click + button
    3) Fill out the window like so:
    Code:
    Application: TextEdit
    Menu Title: Rename...
    Keyboard Shortcut: ⌘R    (or any other unused shortcut that makes logical sense to you)
    
    4) Use shortcut and enjoy renaming items with any extension you want

    As far as I'm aware Textwrangler doesn't even have a rename option as well as the fact that it has no clickable item name in the top bar, but it is a much more full featured text editor.

    Could you not just use "Download Linked File As..." to avoid this issue in the first place?

    Could also have to do with the site you're downloading from. Might want to test with another browser.

    https://discussions.apple.com/thread/3637648?start=0&tstart=0
    http://support.apple.com/kb/TA24293
     
  7. thecork thread starter macrumors newbie

    Joined:
    Jul 25, 2012
    #7
    Cheers, I'll give the keyboard shortcut trick a try.

    Unfortunately I don't have the option to download linked as because it's a hyperlink which redirects to a page that generates an XML file and auto downloads (it's for a licence generator we use at work for our software). Therefore download links as just downloads a essentially a blank htm page basically (kind of hard to explain!).

    Other browsers download the file no problem as an XML, it's just safari's attempt at being clever and simplify things, like what it does with auto extracting zip files that sometimes I just want to stay as a zip :)
     
  8. dBeats macrumors 6502a

    dBeats

    Joined:
    Jun 21, 2011
    #8
    In finder you can set a preference for "always show file extension." When you rename the file with that set, it will not append .txt. They only annoying this is all the Applications show up with .app after them, but if your an advanced user this is nothing.
     
  9. thecork thread starter macrumors newbie

    Joined:
    Jul 25, 2012
    #9
    Ah ok great, thanks for that, ill give that a try. I'm used to having extensions switched on in windows so this is no biggy for me. I have actually just installed firefox specifically for downloading those files just as a workaround as they dont rename them! Stupid that i have to use a complete different browser for just one task but hey ho!
     

Share This Page