Rendering difference between integrated and discrete graphic card

Discussion in 'OS X Mountain Lion (10.8)' started by jianglai, Jul 10, 2012.

  1. jianglai macrumors member

    jianglai

    Joined:
    Feb 9, 2010
    Location:
    New York
    #1
    On my 2010 15-inch MBP, I noticed that when I switch between the integrated Intel graphic card and nVidia GT 330M, the color rendering is very different. When I use the default "Galaxy" wallpaper, with Intel card the top menubar appears more grayish, while when switched to nVidia card, the menubar looks much more bluish. Overall the color on the nVidia card seems more saturated than on Intel card.

    Anyone else also noticing this? I'm on ML GM (12A269), BTW.

    I would have made screenshots to show this, but they look identical when captured, which makes sense since only rendering is different, but not the actual RGB value for each pixel, I think.
     
  2. eyron macrumors newbie

    Joined:
    Jul 1, 2012
    #2
    I have the same MBP and can't see any difference, although when I installed DP3 a while ago I did notice it sometimes looked cooler. The iOS 6 beta also seemed cooler so I assumed it was intentional, but what you describe doesn't sound like it.

    Off topic but as you're on the same system, how are you finding the smoothness of graphics in ML, on both cards? This was my main issue with Lion and was hoping it would be solved with ML but after upgrading to the GM it still seems pretty choppy - hoping it's my installation that's the problem and it will improve when I clean install the final release.
     
  3. jianglai thread starter macrumors member

    jianglai

    Joined:
    Feb 9, 2010
    Location:
    New York
    #3
    General performance is good and snappy. But I do noticed that in Safari PDF viewing becomes more choppy.

    And the discrete vs integrated card situation is worse than I thought. I tried to restart several times and it turns out sometimes there is no saturation problem at all, and sometimes the computer will crash after I switch back to integrated from discrete (turns black screen the moment integrated card is reactivated). It looks like a hardware problem now, but I doubt it since both cards are working fine in Lion.

     
  4. eyron macrumors newbie

    Joined:
    Jul 1, 2012
    #4

Share This Page