repair disc permissions error

Discussion in 'macOS' started by munshi, Oct 6, 2010.

  1. munshi macrumors newbie

    Joined:
    Apr 24, 2009
    #1
    hello,
    i have a problem that everytime i restart my imac (late 2007) i get the blinking folder for 15 minutes up to a couple of hours then it starts up normally. i tried clearing up the PRAM. reset the SMC. and it still happens.
    i tried to do from the system a repair disc permissions and i got back one error that cannot be fixed which was

    <quote> Warning:SUID file"System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents?MacOS/ARDAgent" has been modified and will not be repaired.</quote>

    i have even tried to fix the error from the bootable CD, but same error. i even upgraded to snow leopard but no apparent change. i dont even know if this is the cause of the problem. but all other stuff is OK. even the boot CD hardware thorough check was all ok.

    i still get some noise of the fan when i boot up for a couple of minutes then it goes away.but temperatures are quite good and fan speed is around 800rpm at the moment and no sound is to be heard.
     
  2. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
  3. munshi thread starter macrumors newbie

    Joined:
    Apr 24, 2009
    #4
    ok...that is great. that excludes the error in the system permissions. so what can i do about the blinking folder with the question mark. i tried clearing the PRAM, zapping the SMC. and the hardware test is all ok. hard drive working well. any ideas on what to check else
     
  4. munshi thread starter macrumors newbie

    Joined:
    Apr 24, 2009
    #6
    i followed the steps on the link posted and again the problem occurred. and now some even weirder stuff is happening.
    if i get the grey screen and i put in the OSX disc and try to boot up from it, it fails and ejects the disc. and i dont even get the mac chime at the beginning.

    i tried that with ubuntu CD and same thing. but after a couple of hours it accepts booting from the disc and does not detect any HDD.

    after a couple of more hours. ubuntu is able to detect the HDD, performed a thorough check and all is fine and then inserting the OSX disc does seem to get it up and running.

    just to clear it up. i did the PRAM reset, performed a clean fresh install of the OS. but still the problem is there.

    i thought the HDD might be bust, but if thats the case, why doesnt it boot up from the OSX disc or the ubuntu CD and ejects them? can it be a logicboard problem? and how can i fix that?
     

Share This Page