Repairing invisible folders

Discussion in 'macOS' started by davidlv, May 6, 2010.

  1. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #1
    The installer script for OS X 10.5 crashed during the last part of a clean installation on my G5 (see sig.) and left some folders and aliases to folders visible, that I am sure should be invisible. Updated to 10.5.8 same situation. Running DU to repair permissions does not fix this, nor can I set the folders to invisible using Cmnd+I. The system runs just fine, but the folders and aliases listed below should not be visible.
    Folders Aliases (the folders these point to are also visible)
    bin etc
    cores tmp
    private var
    sbin
    usr
    Volumes

    Any suggestions (rather not do a whole reinstall, it is so time consuming)
     
  2. davidlv thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #3
    Thanks so much, for the most part that worked. :D
    There are still three aliases left on the root level of the startup disk, "Macintosh HD" etc tmp and var. All of these point to folders in the now hidden Macintosh HD/private folder.
    Can I simply delete these aliases? Or does the system need them? In that case, remaking them should work as their parent folder is now hidden.
    Any further advice.
    BTW How did you find that Apple.com thread? Nice find!:cool::eek::cool:
     
  3. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    Glad I was able to help. I think, I Googled something like:

    10.5 invisible folders visible

    I have no idea if you can delete those alias or not. I'm running Tiger so I can't even check my system to see what's supposed to be there.

    If you're concerned about those alias and what was visible before, I suppose you could do an Archive and Install of 10.5. I believe that would make things right without having to start from scratch. You'd still have to install any updates again though.
     
  4. davidlv thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #5
    Well, it looks like I will have to do an Archive and Install, software update absolutely refuses to work. I ran the 10.5.8 from a combo downloaded dmg and pft that was all.
    Thanks again for the help. Much appreciated.
    Update: Did an Archive and Install, all seems to be fine now, but it sure takes a lot of time to do all the updating and resorting out a system so it is useable! This computer is my backup system, and I suppose I could do this stuff in bits and pieces, but it takes some energy to get back into it once you get stopped, so I just did it all at once, about 2-3 hours in all. I am sure other people have a faster system worked out.
    I don't have an external HD I can allocate to this system, so I can't use CCC now. Have to pick up another HD when I get rich I suppose.
    Thanks again for your assistance!
     

Share This Page