Repeated snapshot errors

Discussion in 'macOS Mojave (10.14)' started by ashleykaryl, May 15, 2019.

  1. ashleykaryl macrumors regular

    ashleykaryl

    Joined:
    Jul 22, 2011
    Location:
    UK
    #1
    I was experiencing some glitchy behaviour in High Sierra recently, so I purchased a metal enabled graphics card to upgrade my Mac Pro to Mojave.

    Just prior to the upgrade I had some error messages in disk utility that included these lines:

    Checking snapshot 1 of 15.
    error: inode_val: object (oid 0x3): invalid nchildren (-3)
    Snapshot is invalid.
    The volume /dev/rdisk1s1 could not be verified completely.

    I had tried repairing from the recovery drive, however it wouldn't let me and the trick was to delete all those snapshots in the terminal. It then came up with no issues in disk utility.

    Last night I went ahead and upgraded to Mojave, then checked it in disk utility and you guessed it, the errors are back:

    "Running First Aid on “Mac OS” (disk1s1)

    NOTE: First Aid will temporarily lock the startup volume.

    Verifying file system.
    Volume could not be unmounted.
    Using live mode.
    Performing fsck_apfs -n -l -x /dev/rdisk1s1
    Checking the container superblock.
    Checking the EFI jumpstart record.
    Checking the space manager.
    Checking the space manager free queue trees.
    Checking the object map.
    Checking volume.
    Checking the APFS volume superblock.
    The volume Mac OS was formatted by newfs_apfs (748.1.46) and last modified by apfs_kext (945.260.7).
    Checking the object map.
    Checking the snapshot metadata tree.
    Checking the snapshot metadata.
    Checking snapshot 1 of 1.
    error: directory valence check: directory (oid 0x3): nchildren (176) does not match drec count (179)
    warning: snapshot fsroot tree corruptions are not repaired; they'll go away once the snapshot is deleted
    Checking the extent ref tree.
    Checking the fsroot tree.
    error: directory valence check: directory (oid 0x3): nchildren (203) does not match drec count (206)
    Verifying allocated space.
    Performing deferred repairs.
    error: nchildren of inode object (id 3) does not match expected value
    Deferred repairs failed.
    The volume /dev/rdisk1s1 could not be verified completely.
    File system check exit code is 8.
    Restoring the original state found as mounted.

    Operation successful."

    I can delete the snapshots in the terminal, but each time they are created the error returns and I am then unable to fix it in recovery mode either.

    Other than a clean install, which would hopefully fix this, is there any way to stop these snapshot issues? I've not yet done enough work in Mojave to establish whether it will behave any better, but this is clearly wrong.
     
  2. Mac Hammer Fan, May 15, 2019
    Last edited: May 15, 2019

    Mac Hammer Fan macrumors 6502a

    Mac Hammer Fan

    Joined:
    Jul 13, 2004
    Location:
    Belgium
    #2
    I had a similar problem when updating from HFS+ High Sierra to APFS Mojave.
    I am running Mojave on a Samsung SSD installed in an OWC SATA 3 PCI Accelsior S card.
    Disk utility reported:
    warning: inode_val: object (oid0X111a3) invalid internal-flags (a lot of these)
    too many warnings generated: suppressing subsequent ones
    The volume /dev/rdisk5s1 appears to be OK
    The problem went away when the snapshots were deleted. It seems to be APFS related.
    However, after a few weeks the problem no longer occurs.
    I posted my problem on the Apple Communities too, but no one seems to have an answer.
    Perhaps converting to HFS+ is a solution for you.
    See this thread: https://forums.macrumors.com/threads/ssd-unrepairable-in-mojave.2179261/
     
  3. ashleykaryl thread starter macrumors regular

    ashleykaryl

    Joined:
    Jul 22, 2011
    Location:
    UK
    #3
    This became really brutal before I fixed it the hard way. It wouldn't even let me boot into safe mode and HFS+ isn't an option with Mojave.

    The system was producing new errors with each version snapshot and as long as there was an error I was unable to use disk repair in recovery mode. My gut feeling is that there was some kind of file corruption and later on I even wondered if Apple have a problem with these Samsung SSD drives.

    I only managed to repair the drive in disk utility after formatting various times and messing about with volumes before it removed all trace of the current version and showed as a Samsung SSD with some long file name. I was then able to rename that, pass disk utility repair and start installing.

    Half way through it paused for a long time, so I eventually brought up the installer log and found a bunch of issues, including mention of the drive and something about the base system not being recognise, almost like it was a hackintosh or something. There were also repeat failed attempts to reach the recovery server.

    This forced me to abandon the install, however they offered me the chance to restore from Time Machine, so I started this and two hours later that failed as well. This was not looking good, so I shut down the computer and figured I likely couldn't depend on the recovery drive either.

    By lucky chance I had prepared an installer on a USB stick a couple days before, which I've never done. I plugged that in and actually tried to enter recovery mode but nothing was happening. The grey screen only appeared two seconds after releasing the keys. Everything moved more quickly now and the installer was there. Clearly this was now working off the USB and I think the install only took about 15 minutes.

    At the end it offered the chance to import from Time Machine, but I decided against it and had another night working past 2.00am. It's all fine now on a clean install and I have a bit of configuring to do now, plus some app installs.

    Somebody on the Apple forums had the same problem and it was solved by a clean install. Curiously he was also on a Mac Pro https://discussions.apple.com/thread/8458433

    As an afterthought I think the original drive was so messed up that it could only be properly formatted from an external drive, which was the USB stick in this case. No more error messages now and the install from the USB was fast & painless.
     

Share This Page

2 May 15, 2019