Replace Canada unblocked iPhone in USA

Discussion in 'iPhone' started by oliversl, May 6, 2011.

  1. oliversl macrumors 65816

    Joined:
    Jun 29, 2007
    #1
    Hi,
    I have this situation.

    An iPhone purchased in Canada, factory unblocked, need service in USA. The home button does not work.

    It is in warranty, so, what is the easiest solution?

    Fly to Canada and change it in an Apple Store? Have Apple sent a replacement to a local USA Store?

    Many thanks
    Oliver
     
  2. Steve99 macrumors member

    Joined:
    Mar 11, 2011
    #2
    If the phone was factory unlocked and purchased from Apple then when Apple replaces it for you the replacement will also be unlocked, even if serviced in the US.
     
  3. bbmiLo macrumors regular

    Joined:
    Apr 3, 2011
    #3
    I had a similar issue last month.

    I was using a USA iPhone in China, it's unlocked using a Gevey SIM.
    The home button stopped working.
    I went to the Apple store in Shanghai, they were very polite, but insisted that bounded by new Apple warranty rules, Apple China can not service an iPhone4 unless it's purchased in Greater China market (which includes China, Hong Kong, Macau and Taiwan).
    The reason being, in many service cases they have to replace the board inside, you will get a factory unlocked China version board. Apple does not want to allow that.

    In your case, I imagine USA Apple store should service/replace your phone.

    On the side note, my home button problem was a software issue, after I deleted some game apps, it's working fine.
     
  4. oliversl thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    #4
    Yes, it was purchased in an Apple Store in Canada. Will call the local store and ask again.
    Thanks

    Oliver
     
  5. oliversl thread starter macrumors 65816

    Joined:
    Jun 29, 2007
    #5
    Thanks for the info. The button works, but sometimes you have to press a few times in order to work.

    If its a software issue, a reset should work right? I could start adding games until it fails. Unless you can remember which games were the troubled ones.

    Thanks
    Oliver

     
  6. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #6
    I also had a similar issue ended up a jailbroken app was causing the issue. Sorry to say I don't remember which one. try reinstalling your firmware before you take it in. even if your not jailbroken.
     
  7. sviato macrumors 68020

    sviato

    Joined:
    Oct 27, 2010
    Location:
    HR 9038 A
    #7
    I had this problem too and it was getting to the point where I was fed up and ready to go get a replacement. However, 4.3 came out and after I upgraded to that I've had no problems. Around that time I also disabled any function from a triple-click of the home button, although I'm not sure if it was that which solved the issue
     
  8. bbmiLo macrumors regular

    Joined:
    Apr 3, 2011
    #8

    If the button works, just not responsive, then possibly it's indeed a hardware issue.
    My button did not work at all, no matter how many times and how hard I pressed, it simply stopped working. Restarting, resetting, restoring, wiping all contents, none of those helped.
    I gave up and powered it off. A day later, for the heck of it I powered it on, and it worked like new, go figure, I restored my saved apps/data, but deleted few resource consuming game apps, and no problem since.
     

Share This Page