Replaced battery, now computer wont fully turn on - Mid 2012 Macbook Pro

Discussion in 'MacBook Pro' started by djt511, Jan 29, 2016.

  1. djt511 macrumors newbie

    Joined:
    Mar 15, 2011
    #1
    Hello,


    I replaced my battery on my MBP today with an "OEM" i purchased from eBay. While changing the battery I did the bonehead move of tearing the ribbon that goes from the trackpad to the logic board. I put together the Mac anyway to turn it on and make sure everything else was working, to computer turns on and i type in my password on the login screen when the Mac goes to a screen that says it was shut down unexpectedly and to press any key or wait. When i pres any key i just get a blank screen with fans running on full speed. I can't reset PRAM, that didn't work when i tried.



    Any suggestions, would having a severed track pad cable cause it to not start up properly?



    Thanks in advanced,

    Danny T


    MacBook Pro (Retina, Mid 2012)
     
  2. joe-h2o macrumors 6502a

    Joined:
    Jun 24, 2012
    #2
    Your system is having a kernel panic - are you sure you didn't damage anything else during the install process?

    A damaged trackpad cable should just prevent the trackpad from working. I don't think there are any system-critical functions carried on that cable except perhaps a temperature sensor, so it shouldn't panic because of that - it should just log errors in the console.

    If you'd really damaged it then it would panic on boot, but I suspect it's trying to load some software when you log in that is doing something that causes the now-broken system to bork. Perhaps it's a conflict with the HID stuff due to the broken cable.

    Have you tried it with a mouse plugged in? It could be the "I can't find a mouse!" popup window that launches the bluetooth discovery app on the login screen if OS X can't detect one.
     
  3. makinao macrumors regular

    Joined:
    Dec 27, 2009
    #3
    If you were clumsy enough to tear a ribbon cable, you knows what else you damaged.

    The only other probable cause would be the battery itself.
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    Quite possibly as the trackpad is hardwired therefore a working machine has one all the time. TBH it would be a coincidence of monumental proportions if they two things weren't related. If you have a USB mouse you could try connecting while booting just in case but in my Mac-Mini experience you get a meaningful message if there is no pointing device, but that is on a device without one built in.
     
  5. djt511 thread starter macrumors newbie

    Joined:
    Mar 15, 2011
    #5
    I didn't physically touch anything else during the install, so i'm not sure if anything else got damaged. So not that i know if..

    The last time i booted it i was actually able to log in and it was very sluggish, taking 3-4 minutes to load, once partially loaded i got a screen asking to connect a bluetooth mouse. The next time I restarted so I could connect a mouse i just get a apple logo with the loading bar, its been on that screen for the past 15 minutes now.


    I am trying that now.
    --- Post Merged, Jan 29, 2016 ---
    After loading i am at a Reset Password screen

    Options are
    I forgot my password
    My Password doesn't work when logging in
    My keyboard isn't working when typing my password to log in.

    What do i do from here?
     
  6. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #6
    Keyboard and trackpad are on the same internal USB bus. I'd say you need to fix the trackpad cable. Not very surprising.
     

Share This Page