Replaced HDD with SSD but not recognised

Discussion in 'iMac' started by Moods, Jun 4, 2017.

  1. Moods macrumors newbie

    Joined:
    Jun 4, 2017
    #1
    Hello

    I'm completely new to the Mac world so please be gentle with me if I ask silly questions or don't use the correct terminology!!

    I've recently inherited a 21.5" Mid 2010 iMac that had a faulty HDD. I purchased an 'apparently' compatible 2.5" SSD with a caddy to fit directly to the iMac in place of the dead 3.5" SATA HDD. Old OS was Lion.

    Connected it all up and tried to reinstall OS but the Disk Utility doesn't recognize the SDD. Being a complete Mac novice I'm not sure if I need to remove the SSD and format it or whether there is another issue with will mean its just not compatible.

    I called Apple Support and quite frankly they seemed a little confused and suggested all sorts of steps like downloading El Capitan onto a USB stick and cloning from that onto the SSD, but I'm not sure how this would work given the fact the SSD isn't recognized??

    Any pointers would be really appreciated :)

    Many thanks
    Joel
     
  2. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #2
  3. Moods thread starter macrumors newbie

    Joined:
    Jun 4, 2017
    #3
    --- Post Merged, Jun 4, 2017 ---
    Hi Gjwilly

    Thanks for your reply.

    I simply plugged the new ssd into the 3.5" caddy, mounted it and connected the sata cables. There wasn't a thermal cable involved, is this my issue do you think?

    The disk utility starts automatically after the recovery runs.

    Thanks
    Joel
     
  4. Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #4
    If Disk Utility isn't recognizing it, you're right that you won't get anywhere trying to install to it by some other means.

    The question is why the system won't recognize the drive. There's a few possibilities here-- bad (or incorrectly connected) data or power cables, as @Gjwilly suggested is the most likely. It could be that the drive type you've chosen isn't supported by MacOS. It could be that you got a bum drive, or there's some other component failure in the system.

    What SSD are you trying to use?

    For now, at least, I'd assume this is a hardware problem. Formatting outside the iMac, or trying to copy the system over from a USB stick probably won't help-- and if they did you really don't want a drive in your machine that Disk Utility can't work with.

    The one thing that trying to format outside the machine might help with is confirming if the problem is with the drive itself. If you can get a different machine to access it, then the drive is fine and you can focus on the iMac connections.
     
  5. nambuccaheadsau macrumors 6502a

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #5
    By chance if this is a Samsung EVO drive, 2010 Macs and earlier have problems adjusting to the SATA III 5Gb/ps speed of the EVO. The 2010 iMacs are 3Gb/ps or SATA II. It should have had the heat sink attached so I trust someone has not tried to doctor it.
     
  6. sboychuck, Jun 5, 2017
    Last edited: Jun 5, 2017

    sboychuck macrumors regular

    Joined:
    Sep 19, 2014
    Location:
    Thousand Oaks, CA
    #6
    I had a similar problem in my older Macs (17-inch MacBook Pro and 24-inch iMac).

    I bought a cheap USB3 external "powered" enclosure and formatted the SSD's before I installed them. No problem with the Mac seeing them after start-up.

    I also made a USB install disc of El Capitan and used that to install the OS. I used this software to make the install disc.

    After they were up and running, I use this to make Time Machine back-ups and CCC clones of the drive. Cheap insurance. I have 4TB HGST 7200rpm NAS 3.5 HDD in the enclosure because I got them at a good price, and they are quality drives.

    Hope this helps..
     
  7. Moods thread starter macrumors newbie

    Joined:
    Jun 4, 2017
    #7

    I have reseated the cables and guess what??? I can now see the disk in disk utilities!

    Thanks so much for your help :)
     
  8. Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #8
    Good news! Glad it's working.
     

Share This Page