Replaced Macbook Screen, New Screen not detected

Discussion in 'Mac Basics and Help' started by HugoM, Nov 13, 2009.

  1. HugoM macrumors newbie

    Joined:
    Nov 13, 2009
    #1
    I recently shattered my macbook screen. I quickly ordered a replacement screen (AUO B133EW01 V.0) and installed it. However, when I boot up there is no video and the backlight doesn't come on. The new screen works fine on an old dell laptop. The old screen works on both the macbook and the dell

    I fiddled around for a bit and once I managed to get video, I was then able to go into system preferences and click in the brightness slider and suddenly the backlight worked perfectly, but once I reset the computer I was back to my original problem.

    The only way I can get it to work (and this is probably what I did by mistake the first time) is to plug the backlight into the new screen and video into the old, doing this makes the backlight come on on the new screen on video on the old. Once the computer's booted if I swap the video from the old screen to the new then I can get the new one working - however my computer thinks the old screen is still connected (can see this by typing ioreg -lw0 | grep IODisplayEDID | sed "/[^<]*</s///" | xxd -p -r | strings -6 in terminal)

    By plugging the computer into an external screen and booting with the new screen I can see that in system profiler the new screen isn't listed.

    Does anyone have any idea?

    Thanks.
     
  2. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #2
    Just to throw this out there, did you reset the PRAM?
     
  3. HugoM thread starter macrumors newbie

    Joined:
    Nov 13, 2009

Share This Page