Require password after sleep or screen saver

Discussion in 'Mac OS X Lion (10.7)' started by ray648, Jul 25, 2011.

  1. ray648 macrumors regular

    Joined:
    Jan 10, 2008
    #1
    I upgraded my iMac and MacBook Air to Lion over the weekend. The iMac, which previously did not require a password to get out of the screen saver, decided it now did, and the MacBook Air which previously did, decided that it wasn't going to do that anymore. All the settings looked correct, but I messed about a bit, changed them, came out, went back in, changed them back, and now both work as expected. The MacBook Air, however, is missing the checkbox which is next to this option on the iMac. As a result, this option can not be completely disabled on it. This isn't causing me a problem since its the Air that I want locked down. Just thought I'd post incase someone else is going mad trying to find the missing checkbox. So, if you are trying to turn this option off, and can't work out how, its probably because the checkbox isn't where it should be for some reason. Sorry, but I can't offer a solution.

    On a more positive note: Unlike when I last set this option, it now asks for a password when waking the display from sleep as well as just from the screensaver so you can now disable to screensaver entirely and go straight to sleep monitor while still requiring a password.
     
  2. ray648 thread starter macrumors regular

    Joined:
    Jan 10, 2008
    #2
    Actually, it seems to be misbehaving now. The iMac requires a password to wake from screen saver/sleep display even though the option is turned off.
     
  3. C64 macrumors 65816

    C64

    Joined:
    Sep 3, 2008
    #3
    You mean: System Prefs > Security > General > Require password checkbox?

    Same place on SL / Lion here as far as I can tell.
     
  4. ray648 thread starter macrumors regular

    Joined:
    Jan 10, 2008
    #4
    Thats the one. The checkbox is not ticked on the iMac, but it acts as if it is. On the MacBook Air, the checkbox is just not there at all. The rest of the window looks the same, and you can choose how long before the password is required, but theres no checkbox to disable it.
     
  5. dcorban macrumors 6502a

    dcorban

    Joined:
    Oct 29, 2007
    #5
    I had the new MBA for a few days and it behaved the same as your iMac. Despite having the checkbox unchecked, it still prompted for a password after sleeping. I didn't bother to look much more into it since I planned to return the system.
     
  6. JSchur macrumors newbie

    Joined:
    Sep 23, 2008
    #6
    Same here. I have the check-box unchecked but I am asked for the password after the screen dims or the machine sleeps... I don't use a screen saver but I'm sure that it would do the same. Also, I selected "Name & Password" for the login screen but it still gives me a list of users. Bugs? I guess we'll just have to wait for a update and see.
     
  7. wackymacky macrumors 68000

    wackymacky

    Joined:
    Sep 20, 2007
    Location:
    38°39′20″N 27°13′10″W
    #7

    You should still be able to do if from the command line in an admin account if you are comfortable doing so.

    The only benifit from this is if you also turn off auto-restart on power failure, automatic longin when being turned on and secure the virtual memory.

    Though this really only protects you from a basic user.

    i'm not sure if you still can in lion, but in 10.6 you coud just boot-up in single user mode and get past this protection unless firmware password was set.

    # Suggested Setting:
    # Enable Require password to wake this computer from sleep or screen saver.
    sudo defaults -currentHost write com.apple.screensaver askForPassword -int 1

    # Disable Automatic login.
    sudo defaults write /Library/Preferences/.GlobalPreferences\
    com.apple.userspref.DisableAutoLogin -bool yes


    # Disable automatic login.
    sudo defaults write /Library/Preferences/.GlobalPreferences\
    com.apple.autologout.AutoLogOutDelay -int 0


    # Enable secure virtual memory.
    sudo defaults write /Library/Preferences/com.apple.virtualMemory\
    UseEncryptedSwap -bool yes



    # Disable Restart automatically after power failure.

    sudo pmset -a autorestart 0

    # Available Settings:
    # 0 (OFF) or 1 (ON)
     
  8. Eriamjh1138@DAN macrumors 6502

    Eriamjh1138@DAN

    Joined:
    Sep 16, 2007
    Location:
    BFE, MI
    #8
    Be sure to click the lock before making changes.
     
  9. CyBeRino macrumors 6502a

    Joined:
    Jun 18, 2011
    #9
    The check box goes away when FileVault is enabled.
     
  10. JSchur macrumors newbie

    Joined:
    Sep 23, 2008
    #10
    Mystery solved

    Well, it appears that this issue is a result of Filevault being enabled in Lion. I originally had my iMac and MBP setup with Filevault encryption and had this issue on both machines. Yesterday I disabled Filevault on the iMac and it went back to behaving as it did in Snow Leopard and earlier. Also, Lion's Filevault screws with the login functions. With "Show Name & password" selected as the login option, I would get a list of users and had to click on a user and enter the password. Now, without Filevault, it is back to normal.
     

Share This Page