reserved characters

Discussion in 'OS X Yosemite (10.10)' started by Tech198, Jun 22, 2015.

  1. Tech198 macrumors G4

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #1
    Since the dot "." is OS X is system reserved, when u try and save a file begging with . or even ... you get a pop up about the cause, and if u preceded to ignore and continue saving, the file will be hidden in OS X.

    This is annoying particularly in iTunes when names of songs begin with .... or albums begin with the same (Britney Spears ....One More Time) for example...

    Aside from deleting the track, or adding a different character in front, what do you do to get around this ? I use _. but seriously, it looks awful and messes up your iTunes library. I don't many many songs luckily, but albums yes.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Tbh, I've not run into any of those issues. I let iTunes handle the naming of my music either on importing and/or buying it from the iTunes store.
     
  3. Toutou macrumors 6502a

    Toutou

    Joined:
    Jan 6, 2015
    Location:
    Prague, Czech Republic
    #3
    It's simple - a file beginning with a dot is a hidden file. Not "system reserved" - hidden. It's been like that for a long time and it's not OS X specific - it's a convention. There's no way around that. Insert your favorite character in front :D
     
  4. ccmath macrumors newbie

    ccmath

    Joined:
    Sep 1, 2010
    #4
    If you want a file to begin with … type Option+Semi-Colon
     

Share This Page