Resolved Resizing and Adding Partition Killed Windows 7 Bootcamp Partition

Discussion in 'Windows, Linux & Others on the Mac' started by owntheweb, Feb 7, 2015.

  1. owntheweb, Feb 7, 2015
    Last edited: Feb 7, 2015

    owntheweb macrumors newbie

    owntheweb

    Joined:
    Feb 7, 2015
    Location:
    Colorado
    #1
    Hello Mac Gurus,
    Once upon a time a year or so ago I installed Windows 7 on a Bootcamp partition with the help of my IT team. It was a smaller partition as I was only planning to use windows for my music composition software that required it... I didn't realize how much space Windows 7 required (what a hog!) and drive space was limited. After installing a video game recently (also a medium sized porker), I decided to to add some space.

    Uh oh! :mad:

    [​IMG]

    Using Mac Disk Utility, I reduced my Mac partition and added another MS-DOS (FAT) partition in hopes of making another write access drive accessible to Windows. This resulted in Bootcamp no longer being a bootable option (holding down option key when booting - drive not visible). I can still access my files via Mac and have backed everything up.

    I just hope not to reinstall Windows as the music software is finicky and takes FOREVER to download. It's also tricky as I purchased a CD... and don't have a CD drive... and don't want to upgrade to the new online subscription version just yet.

    Mac Info: MacBook Pro (Retina, Mid 2012)
    Running: OS X Yosemite 10.10

    Reading similar posts from two years ago, I figured I should post something new. To speed things up based on those posts, I ran this command:

    Code:
    sudo gpt -r -vv show disk0
    It resulted in this:

    Code:
    gpt show: disk0: mediasize=500277790720; sectorsize=512; blocks=977105060
    gpt show: disk0: Suspicious MBR at sector 0
    gpt show: disk0: Pri GPT at sector 1
    gpt show: disk0: Sec GPT at sector 977105059
          start       size  index  contents
              0          1         MBR
              1          1         Pri GPT header
              2         32         Pri GPT table
             34          6         
             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
         409640  486328120      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
      486737760    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
      488007296        384         
      488007680  234964992      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
      722972672  254132224      5  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
      977104896        131         
      977105027         32         Sec GPT table
      977105059          1         Sec GPT header
    I ran this command:

    Code:
    sudo fdisk /dev/disk0
    Results:

    Code:
    Disk: /dev/disk0	geometry: 60821/255/63 [977105060 sectors]
    Signature: 0xAA55
             Starting       Ending
     #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
    ------------------------------------------------------------------------
     1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
     2: AF 1023 254  63 - 1023 254  63 [    409640 -  486328120] HFS+        
     3: AB 1023 254  63 - 1023 254  63 [ 486737760 -    1269536] Darwin Boot 
     4: 0B 1023 254  63 - 1023 254  63 [ 488007680 -  234964992] Win95 FAT-32
    I installed this: http://sourceforge.net/projects/gptfdisk/

    Then ran this:

    Code:
    sudo gdisk -l /dev/disk0
    Results:

    Code:
    GPT fdisk (gdisk) version 0.8.10
    
    Warning: Devices opened with shared lock will not have their
    partition table automatically reloaded!
    Partition table scan:
      MBR: hybrid
      BSD: not present
      APM: not present
      GPT: present
    
    Found valid GPT with hybrid MBR; using GPT.
    Disk /dev/disk0: 977105060 sectors, 465.9 GiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): 00006089-5C8B-0000-1202-00008B620000
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 977105026
    Partitions will be aligned on 8-sector boundaries
    Total free space is 521 sectors (260.5 KiB)
    
    Number  Start (sector)    End (sector)  Size       Code  Name
       1              40          409639   200.0 MiB   EF00  EFI system partition
       2          409640       486737759   231.9 GiB   AF00  Customer
       3       486737760       488007295   619.9 MiB   AB00  Recovery HD
       4       488007680       722972671   112.0 GiB   0700  THE FAT
       5       722972672       977104895   121.2 GiB   0700  BOOTCAMP
    I'm going to go for a walk now and will not destroy anything else...

    Any thoughts on how I should proceed to fix my Windows partition? I truly appreciate the feedback in advance! :)
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Well it may or may not be too late, but I recommend the use of Winclone, which backs up your bootcamp partition. Always have a backup before doing any partition work (including your OS X partition).

    Secondly, did you try undoing your steps, i.e., remove the FAT partition and resize the OSX partition back to what it was?
     
  3. owntheweb thread starter macrumors newbie

    owntheweb

    Joined:
    Feb 7, 2015
    Location:
    Colorado
    #3
    Hello maflynn,
    Thanks for the quick response! :D

    I should have known better before mucking around with partitions.

    Sadly no WinClone. I do keep my Mac backed up via Time Machine and Time Capsule. Windows is being left out, using basic S3 services to keep important files there backed up (but not OS). I do have access to my separate work MacBook which has helped me in restoring files when my Time Machine backup wasn't fully recognized (that's another long story that ended well).

    I did attempt to remove the extra partition and resize the Mac partition. There was some extra empty space there that I tried to approximate. No luck, and I didn't recall the original exact size.

    Another related post I'm looking into that gives me hope (not understanding everything here just yet):
    https://discussions.apple.com/thread/4144252?start=0&tstart=0
     
  4. owntheweb thread starter macrumors newbie

    owntheweb

    Joined:
    Feb 7, 2015
    Location:
    Colorado
    #4
    Fixed it!

    I followed the steps here: https://discussions.apple.com/message/19047693

    Windows is bootable once again. Whoohoo!

    Now to the next challenge: Seeing my Mac partition (new: lost it) again in Windows, and also seeing the new FAT partition there. I'll post separately if I get stuck. ;)
     

Share This Page