Resizing and expanding logical HFS+ partition on Extended Parition

Discussion in 'Windows, Linux & Others on the Mac' started by dulcificum, Jul 23, 2009.

  1. dulcificum macrumors newbie

    Joined:
    Jul 23, 2009
    #1
    I am dual booting XP Pro and OS X on my NC10. I have XP Pro installed on the main partition with a FAT32 partition for files that can be read by both OSes (see attached image for two views of the partitions).

    I then installed OS X on an extended partition. Unfortunately, I had another 5GB partition also on that extended partition. I now want to delete the spare 5GB partition and non-destructively reallocate the space for the OS X partition - I want to expand it to be one big partition with my bootable OS X install still on it.

    Unfortunately, I can't find any way to do this in Partition Magic. Is it possible with GParted/BootItNG/iPartition or any similar software? If so, which and how? The NC10 has no CD drive so solutions that work from OS X or XP or a bootable USB stick would be preferred.

    Any advice would be highly appreciated. Cheers,
     

    Attached Files:

  2. dulcificum thread starter macrumors newbie

    Joined:
    Jul 23, 2009
    #2
    Has anyone used any of the software I mentioned or sucessfully resized their OS X partition?
     
  3. dulcificum thread starter macrumors newbie

    Joined:
    Jul 23, 2009
  4. dulcificum thread starter macrumors newbie

    Joined:
    Jul 23, 2009
    #4
    Right, finally solved this but it wasn't by using any partitioning tools. A combinaiton of Partition Magic, GParted and Disk Utility proved to be useless.

    In the end I deleted the recovery partition to make room for a new primary partition and used CCC/SuperDuper! to clone the OS X partition across. However this didn't work and I thought it was due to CCC/SuperDuper failing. I tried to make an image but that didn't work either (I was using a FAT32 disk, doh!).

    Finally, after many hours, I found out that the clones didn't work because of chain0. It cannot cope with multiple AF parititions. I had to use tboot instead which fixed things instantly.

    And thus I have finally solved this by cloning and using tboot.
     

Share This Page