Resizing or deleting Yosemite partition

Discussion in 'OS X Yosemite (10.10)' started by Foss, Oct 2, 2014.

  1. Foss macrumors 6502

    Foss

    Joined:
    Sep 11, 2008
    #1
    So I've had an interesting month messing with the partitions on my rMBP. Long story short, I was always running out of space on my teeny tiny 250 GB SSD between my Mavericks and Yosemite partition. So with the Yosemite GM being released to devs, I decided to once and for all to get rid of my Mavericks partition (which I hardly use now anyways) and reclaim that partition to expand space on my Yosemite partition. These are the steps that I followed:

    1. Backup Yosemite partition via Disk Utility. For whatever reason, I had to either boot into my Mavericks partition or Command+R mode to use Disk Utility to create a new image on my external drive of my Yosemite partition. Perhaps my external drive got corrupted but this image ended up being useless in the end anyways. I would highly recommend to Time Machine the Yosemite partition to be restored later.

    2. After backing up, delete the Yosemite partition.

    3. Then I deleted my Mavericks partition (from Command+R) bootup mode. Then created single partition for my whole drive. Then restore from Time Machine of my Yosemite partition on my single whole partition.

    I wasted a lot of time to get my restore from disk image to work. It would not mount. Disk Utility "Repair Disk" did nothing really. I tried multiple fixes from different posts including using Disk Warrior, "fsck -fy", etc, none of which worked. This method also works well if you want to shrink your other partitions and then reclaim space for your Yosemite partition. AFAIK, there is no easy way to simply resize the Yosemite partition. Hopefully, this is useful to someone as I had spent several hours trying to get this to work (till very late at night) as this is also my work machine.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I'm late to the party, but what happened is when you install Yosemite on a second partition it creates a core storage volume that can't be cloned or resized and used like you tried with Disk Utility.

    There is a long thread here on this.
     

Share This Page