Resolution Issue after some toying around (user error)

Discussion in 'MacBook Pro' started by TatsuTerror, Jun 15, 2012.

  1. TatsuTerror, Jun 15, 2012
    Last edited: Jun 15, 2012

    TatsuTerror macrumors regular

    Joined:
    Jan 1, 2008
    #1
    Hello,

    I have a retina macbook pro, and I am very frightened -- I installed an app called SwitchResX, couldn't really figure it out, and uninstalled it (also searched for possible other traces of the app but couldn't find any. When I went to change my resolution, was really funky. The "more space" option says "looks like 1440 by 900", and the one directly to the left of that says "looks like 960 by 600". The "bigger text" options change nothing and have no resolutions listed. I assume maybe the app messed with something because it was around the time that I installed it that this happened

    I'm not sure what the heck I did, but I can't get to the higher res options anymore :/

    Someone have any ideas on how I can reset this? Or something? I'm really upset about it and don't have time to go to the apple store...
     
  2. Sean Dempsey macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #2
    If it is a new computer, you can do a restore from the install partition, restart the computer and hold down option as it boots, and there will be a restore partition option.
     
  3. TatsuTerror thread starter macrumors regular

    Joined:
    Jan 1, 2008
    #3
    Thanks for letting me know -- I'll do it as a last resort but would like to try some more troubleshooting first...

    (I don't have time machine set up)
     
  4. that1guyy macrumors 6502

    Joined:
    Nov 11, 2011
    #4
    I think Apple designed that "gatekeeper" feature for people like you. Don't install anything if you don't know what it is and what it does. Jeez.

    Also, you should add to the title of your topic that this is because of user error, and not a problem with macbook pros because your title will attract worried people.
     
  5. eron macrumors 6502

    Joined:
    Dec 2, 2008
  6. TatsuTerror thread starter macrumors regular

    Joined:
    Jan 1, 2008
    #6
    - We all make mistakes. I came here for some assistance...

    - I've changed the title to reflect that it was user error.


    Unfortunately no luck.
     
  7. Ljohnson72 macrumors 6502a

    Ljohnson72

    Joined:
    Dec 21, 2008
    Location:
    Denver, Co
    #7
    Apparently messing around with SwithcResX deletes a file or two. Either this one:
    Code:
    /System/Library/Displays/Overrides/DisplayVendorID-610/DisplayProductID-a00f
    Or this one:
    Code:
    /System/Library/Displays/Overrides/DisplayVendorID-610/DisplayProductID-a00e
    Both files have the same contents.

    Sean Dempsey posted the file contents in another thread: http://forums.macrumors.com/showthread.php?p=15052764#post15052764

    So if you replace the missing file(s) and reboot, it should fix it. :)
     
  8. TatsuTerror thread starter macrumors regular

    Joined:
    Jan 1, 2008
    #8
    Worked! Thanks for the tip!
     
  9. John566 macrumors member

    John566

    Joined:
    Mar 6, 2008
    #9
    Thank you! This also worked for me.
     
  10. EpsilonExordium macrumors member

    EpsilonExordium

    Joined:
    Nov 28, 2008
    Location:
    Austin, TX
    #10
    Forgive me for being a noob - the same thing happened to me. What am I supposed to do to fix this issue?
     
  11. daleski75 macrumors 68000

    daleski75

    Joined:
    Dec 10, 2008
    Location:
    Northampton, UK
    #11
    Isn't the answer directly above your post?!?
     
  12. john123 macrumors 68020

    john123

    Joined:
    Jul 20, 2001
    #12
    You scroll up.
     

Share This Page