Resolved: Another AirPlay Issue: Always Off

Discussion in 'OS X Mountain Lion (10.8)' started by smeg36, Jul 27, 2012.

  1. smeg36, Jul 27, 2012
    Last edited: Jul 27, 2012

    smeg36 macrumors regular

    Sep 16, 2009
    I have a 2012 MacBook Air, Mountain Lion, and an Apple TV 3. They're all connected wirelessly through a Time Capsule. I tried out AirPlay Mirroring today, and ran into a problem. When I chose the Apple TV from the list to AirPlay to it will briefly change the resolution on my Air, flash on the tv, then return to the regular screen without being mirrored. If I try it again, it will start displaying on my tv, but has black bars all around the screen, and the settings on the Air under Display Preferences says AirPlay mirroring is Off. I try to select the Apple TV, but it won't stay selected. The additional settings for resolution and overscan briefly flash, then disappear.

    Of course I tried resetting my computer, resetting the Apple TV, restoring the Apple TV, and going through all the settings on the Apple TV to see if changing any of them helped. Nothing did. I tried searching, and while I found a lot of other problems with AirPlay on Mountain Lion, I didn't find this one. Any other ideas to try and get it working? I guess the next step is trying to reinstall Mountain Lion.

    Edit: I finally got it working by using wired instead of wireless on the Apple TV, and turning the wifi off then back on on the Air. I can't imagine why that did it when all the power cycles in the world didn't work. But I'm still running into some of the other issues that I read about when trying to find a solution to my problem. And after disconnecting it won't work again.
  2. RoboCop001 macrumors 65816

    Oct 4, 2005
    Toronto, Canada
    I had the same problem with my MacBook Pro (early 2011).

    A quick restart of the Apple TV (under Settings - General I think) solved the problem. Not sure why it's still not working for you.
  3. smeg36 thread starter macrumors regular

    Sep 16, 2009
    I tried that, didn't work for me. After the one time I got it to work using a wired connection and powering the wireless on my Air off then on, I can't get it to work again. I'm currently restoring Mountain Lion in hopes that'll do something.
  4. dhodges macrumors newbie

    Jul 27, 2012
    Apple TV software version

    I had this same problem until I checked my Apple TV software version.
    There was an update available and I applied it and now Airplay works great.
    Apple tv software should be at 5.01
  5. smeg36 thread starter macrumors regular

    Sep 16, 2009
    I did that too. There weren't any updates available, so I restored it completely just to make sure the firmware was reapplied to the most recent.
  6. smeg36 thread starter macrumors regular

    Sep 16, 2009
    I figured out what it was. It's an incompatibility with an app I had installed called Boom, which boosts the volume of the internal speakers. I'm not sure why that would break AirPlay, but it did. So if anyone else runs into this problem, and you have Boom installed, uninstall it (or just quit it when you want to use AirPlay), and it will fix the issue.
  7. Bfarmer38119 macrumors member

    May 27, 2012
    Thank you for your post. This has been driving me crazy. Never thought that Boom would be the issue. I even received an update for Boom this week that didn't address the issue.
  8. smeg36 thread starter macrumors regular

    Sep 16, 2009
    I contacted them about it when I discovered that was the issue. They replied that even the new version, 1.5, has this bug and they are working to fix it.
  9. Sumalee macrumors newbie

    Jun 30, 2012
    I had the same issue as you and once I quitted boom everything worked fine. Thanks a lot of saved me from an head ache ;)

Share This Page