Resolved: How do I paste without including formatting?

Discussion in 'iOS 10' started by ardchoille50, Dec 2, 2016.

  1. ardchoille50 macrumors 68020

    Joined:
    Feb 6, 2014
    #1
    I'm using the Notes app that ships with iOS 10.1.1 on an iPad Pro 9.7. I copied some text from a web page and attempted to paste it into the Notes app but found that formatting (links, bold text, etc.) was brought over as well. I know this is possible in macOS, but how do I paste without the formatting in iOS? If that is not possible, can I at least highlight the newly-pasted text and remove the formatting?
     
  2. Lappen71 macrumors regular

    Lappen71

    Joined:
    Nov 16, 2012
  3. ardchoille50, Dec 2, 2016
    Last edited: Dec 2, 2016

    ardchoille50 thread starter macrumors 68020

    Joined:
    Feb 6, 2014
    #3
    I'm inclined to agree, I cannot see any way to do this. I wonder if I would be better off using a different app for notes.

    Edit: Notability allows for pasting text without including formatting and it has iCloud sync. I'll try using that and see how it fits my needs.
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    You might be able to do it if you perhaps paste somewhere where formatting isn't supported--perhaps some app that supports just plain text, or some web site that has a text field that doesn't support formatting, or something like that--and then copying it from there without formatting and pasting that in where you need it.
     
  5. ardchoille50 thread starter macrumors 68020

    Joined:
    Feb 6, 2014
    #5
    That's an idea, I was doing that on my Mac mini before I learned that I could paste without formatting. Thank you.
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    That's pretty much where my line of thought came from--from doing this on a computer at some point in time where I would use just the regular Notepad/TextEdit for these types of purposes.
     
  7. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #7
    When you can, click Share... instead of Copy, and use the copy button in the share sheet.
     
  8. ardchoille50 thread starter macrumors 68020

    Joined:
    Feb 6, 2014
    #8
    Thank you, Jessica, that worked perfectly! This proves that iOS has two forms of copy - one with formatting and one without. I'll have to remember to try that from now on.
     
  9. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #9
    Good to know.

    Unless one has some bug somewhere. But given the usefulness, hopefully it's by design.
     
  10. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #10
    Oh, it's by design. If you were to AirDrop someone it, they get it as a .txt and you're prompted to open it in whatever.
     
  11. ardchoille50 thread starter macrumors 68020

    Joined:
    Feb 6, 2014
    #11
    That makes sense, .txt doesn't support markup. Perhaps the stock Notes app uses .rtf format by default.. that would explain some things.
     
  12. lelisa13p macrumors 68000

    lelisa13p

    Joined:
    Mar 6, 2009
    Location:
    Atlanta, GA USA
    #12
    I just used the Notability trick and it works. It's nice to have options. Thanks for sharing that one.
     
  13. Abazigal macrumors 604

    Abazigal

    Joined:
    Jul 18, 2011
    Location:
    Singapore
    #13
    Not sure if you are still interested in additional solutions, but I found that you can save text snippets to Copied, then when you paste them, the formatting is stripped out as well.
     
  14. ardchoille50 thread starter macrumors 68020

    Joined:
    Feb 6, 2014
    #14
    Copied? Is that an iOS app?
     
  15. Abazigal macrumors 604

    Abazigal

    Joined:
    Jul 18, 2011
    Location:
    Singapore
  16. ardchoille50 thread starter macrumors 68020

    Joined:
    Feb 6, 2014
    #16
  17. deany macrumors 68030

    deany

    Joined:
    Sep 16, 2012
    Location:
    North Wales
    #17
    Thanks to all that have helped, I have tried the shared>copy and works fine now.
    the glitch hopefully will be fixed by apple.
     
  18. gaanee macrumors 6502a

    Joined:
    Dec 8, 2011
    #18
    How do you copy-paste without formatting on Mac? I usually first copy-paste from a web page to the adress bar.. that removes all the formatting then again copy from there and paste... sounds silly, but fast enough to do. I would like to know if there a better way to do this...though I am on windows PC.

    --- Post Merged, Dec 12, 2016 ---
    That is very helpful to know... always wondered why that copy option is there in the share sheet... never used it though because the most obvious way to copy-paste is to press-hold and copy.
     
  19. ardchoille50 thread starter macrumors 68020

    Joined:
    Feb 6, 2014
    #19
    I don't have my Mac in front of me, but if I remember correctly, the Edit menu in macOS has a couple different paste options.
     
  20. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #20
    I use this trick where you just remap Paste and Match Style to Command-V (what Paste is to begin with) with the built-in OS shortcuts feature (under Keyboard in System Preferences). You set it so it works in All Applications.
     
  21. dalbanese macrumors newbie

    Joined:
    Feb 4, 2009
    #21
    Thanks for solution. But note: does not carry over format like billeted number lists (1-5 became a series of zeroes for me).
     
  22. ArcticBlue00 macrumors member

    ArcticBlue00

    Joined:
    Mar 4, 2016
    Location:
    South Korea
    #22
    Omg thank you for the great tip! You saved me!
     

Share This Page