[Resolved] OSX stuck with 'old data'?

Discussion in 'OS X Mavericks (10.9)' started by oYx, Nov 21, 2014.

  1. oYx, Nov 21, 2014
    Last edited: Nov 26, 2014

    oYx macrumors regular

    Joined:
    Sep 2, 2007
    Location:
    London
    #1
    Not sure when this started, but I begin to notice that every time I start Safari, the same tabs would open even after closing them before exiting the browser.

    This seems to be recurring across other apps. For example, Quicksilver would always ask me if I want to read the update log for the new version, even though I had clicked "Ignore" many times before.

    Vox (music player) would always bring me through the start-up introduction even though I have completed it the first time.

    Some apps would always trigger the "Allow apps to control your computer" even after having approved it many times over.

    I tried the following:

    Clearing out the ~/Library/Cache folder and restarting. Did not work.

    Repairing disk permissions. Did not work too.

    Exited one of the above apps, deleted its preference files, open it again. Did not work.

    Hope someone could provide a solution! :)
     
  2. Traverse macrumors 603

    Traverse

    Joined:
    Mar 11, 2013
    Location:
    Here
    #2
    Well, I don't know about some of those apps but for Safari set your "general" pane in preferences similar to mine. Do not have "Restore Last Session" enacted or a specific homepage set if you don't want that for "New windows open with" and "new tabs open with".
     

    Attached Files:

  3. oYx thread starter macrumors regular

    Joined:
    Sep 2, 2007
    Location:
    London
    #3
    Thanks for the reply!

    I have tried that before and it did not work. Even tried resetting Safari.

    The way the other apps are behaving makes me think that it is a system issue somewhere.
     
  4. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #4
    I believe it's a BUG
    (Same thing happens to me -- and I *definitely* have that silly "open previous applications" thingy UNchecked).

    To aggressively "freshen up" Safari, you can go to
    YourUserName/Library/Safari
    and clear out everything *except* bookmarks.
     
  5. oYx thread starter macrumors regular

    Joined:
    Sep 2, 2007
    Location:
    London
    #5
    The issue is finally resolved with Onyx: http://www.titanium.free.fr/onyx.html

    Installed Onyx. Went to "Cleaning" and selected all options under "System". After the cleaning, it prompted for a reboot. Rebooted and Mavericks is back to normal. :cool:
     
  6. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #6
    I'm a big fan of Onyx. Always a good idea to do some sort of a 'backup' before running these types of programs; however, I've *never* had anything go bad from using it, and, I use it minimum once per week.
     

Share This Page