Resolved - temporarily: Group 80 and 0 - 10.9 install

Discussion in 'OS X Mavericks (10.9)' started by davidlv, Oct 26, 2013.

  1. davidlv, Oct 26, 2013
    Last edited: Apr 4, 2014

    davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #1
    After booting from the Recovery partition, and running Repair Permissions from Disk Utility, the issue below no longer appeared. For a while, now its back.
    Running Repair Permissions with Mavericks 10.9 produces the following results.
    “Group differs on “Library/Printers/InstalledPrinters.plist”; should be 80; group is 0.
    Permissions differ on “Library/Printers/InstalledPrinters.plist”; should be -rw-rw-rw- ; they are -rw-r--r-- .
    Repaired “Library/Printers/InstalledPrinters.plist”

    What is the meaning of “Group should be 80, is 0”?
    Disk Utility says it repairs the file, but it gets the same error every time.
    Is this something to be concerned about? Should I just try deleting the file and then reinstalling my printer driver (Canon)?
     
  2. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #2
    Got the same issue on 10.9, and I have no printers at all/none installed. Methinks it's yet another bug.

     
  3. crjackson2134 macrumors 68040

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #3
    I get the same error too. Add me to the list.

    Code:
    Verifying permissions for “Macintosh HD”Group differs on “Library/Printers/InstalledPrinters.plist”; should be 80; group is 0.Permissions differ on “Library/Printers/InstalledPrinters.plist”; should be -rw-rw-rw- ; they are -rw-r--r-- .
    Permissions verification complete
     
  4. ABC5S Suspended

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #4
    I get same OP with a Canon Printer installed. I'm not concerned since everything else is working fine including the Printer.
     

    Attached Files:

  5. snsd macrumors newbie

    Joined:
    Jul 22, 2013
    Location:
    CA
    #5
    Got the same issue here and I have no printer installed. I guess it's just another bug.
     
  6. Batt macrumors 65816

    Batt

    Joined:
    Dec 17, 2007
    Location:
    Syracuse, NY
    #6
    Feel free to ignore it, it's meaningless. Mysterious stuff like this happens all the time and never affects anything.
     
  7. ui-guy macrumors newbie

    Joined:
    Oct 10, 2013
    #7
    Glad your problem has been resolved. I'm not sure why that particular file has the wrong permissions, but I can explain what the DU explanation means. Group 80 is the UNIX Administrator (admin) group and group 0 is the "wheel" or root group (equivalent to when you use "sudo" in Terminal.app). All users with administrative privileges are in wheel, so the "error" that DU is reporting is kinda moot. See Disk Utility's Repair Disk Permissions messages that you safely ignore.
     
  8. ultraspiracle macrumors member

    Joined:
    Sep 21, 2012
    #8
    get the same thing - and it does not affect anything. Be thankful that permission repair only flags this issue. It's nothing...really...
     
  9. sagav macrumors newbie

    Joined:
    Apr 4, 2014
    #9
    ANSWER: InstalledPrinters.plist”; should be 80; group is 0.

    I found a way to get rid of the permission error:

    I went to Computer/Library/Printers and found the file called "InstalledPrinters.plist". Select file and press "command i" (to get info). On the bottom of the info box is a lock: I unlocked the file. The next time I repaired permissions, the error was gone!
     
  10. davidlv thread starter macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #10
    Unfortunately that was not the case with my MBP.
    This may actually be a non-issue, as the printer works fine even when that error appears.
    I checked the Get Info pane, the file was already unlocked, but only the system had read and write permissions, so I changed that so wheel had read and write permissions too. Following that change DU doesn't spit out that error! On another Mac, Macmini 2011, Everyone also had read and write permissions, and no error in DU.
    This may be the simple fix required.
     
  11. dmccloud macrumors 6502a

    dmccloud

    Joined:
    Sep 7, 2009
    Location:
    Anchorage, AK
    #11
    Unlocking the file just allows you to change permissions. What I discovered is that the file is set to "Read Only" for both "Wheel" and "Everyone". If you run Disk utility, it changes both of those to "Read/Write". Manually changing them from the Get Info window will resolve the issue, even though it's really nothing to be concerned with.
     

Share This Page