(Resolved) Time Machine not working on Mojave

Discussion in 'macOS Mojave (10.14)' started by navaira, Oct 4, 2018.

  1. navaira macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #1
    Exactly as this thread says: https://discussions.apple.com/thread/8561149

    I can't do a TM backup either to a drive connected with a cable or to a network drive. Both worked perfectly well until Mojave update. According to the thread above, Apple engineers don't seem to know what the problem is. I thought my network drive somehow broke, then connected a regular external SSD. Same problem. "Time Machine couldn't back up to [drive name]".

    Anybody else?
     
  2. Howard2k macrumors 68020

    Howard2k

    Joined:
    Mar 10, 2016
    #2
    No. I did a clean install and Time Machine worked incredibly well for puling my data back. I use both external HDD and NAS and both worked. I was amazed actually.

    I have battery/power issues with Mojave but Time Machine has been incredible.
     
  3. Venderious macrumors regular

    Venderious

    Joined:
    Dec 15, 2014
    Location:
    Groningen
    #3
    Had a similar problem a few days back, just after upgrading to Mojave. You can refer to this thread regarding my issue: Time Machine can't complete backup. I'd suggest that you initiate Time Machine like normal, but try opening the console, and when it fails filter the console to only display the process called 'backupd'. This will display all the error messages that Time Machine has encountered. From there you might be able to find the problem, it could be (like in my case) a corrupted file.
     
  4. navaira thread starter macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #4
    Restoring is not a problem, I can't do a new backup. Do those work for you?

    I have this:

    Oct 4 15:41:13 MBP backupd[10794]: objc[10794]: __weak variable at 0x7ff945a00010 holds 0x7ff945a00045 instead of 0x7ff945a01290. This is probably incorrect use of objc_storeWeak() and objc_loadWeak(). Break on objc_weak_error to debug.
    Oct 4 15:49:49 MBP backupd[54431]: objc[54431]: __weak variable at 0x7fa9f9b005c0 holds 0x7fa9f9b00004 instead of 0x7fa9f9b00290. This is probably incorrect use of objc_storeWeak() and objc_loadWeak(). Break on objc_weak_error to debug.

    Edit: found this https://discussions.apple.com/thread/7686484 – logged out of iCloud Drive, let's see...

    Edit 2: I used this command

    Code:
    log show --predicate 'subsystem == "com.apple.TimeMachine"' --info --last 4h | grep Error
    ...and it does appear I had one borken file. Deleted it, trying again.
     
  5. Howard2k macrumors 68020

    Howard2k

    Joined:
    Mar 10, 2016
    #5
    Yep, new backups work too... Although I have only backed up to my NAS, I have not backed up to my external HDDs yet. Keeping those untouched since Mojave has some issues and I may need to roll back.
     
  6. navaira thread starter macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #6
    I still don't know what and why happened and wonder if APFS is to blame...

    I had a song on a Madonna album that kept causing errors. I deleted the song. Somehow it still caused an error despite not being there, so I...discovered there were two folders called Madonna. I have separate iTunes backups, so I deleted one of the folders. The other one disappeared. Then reappeared. I tried to delete it, and Finder told me something like "the file can't be deleted because the file can't be found"...then presented me with three folders called Madonna. Terminal didn't see any of the three, luckily, and after I force-relaunched Finder it didn't either. And then the backup worked.

    At High Sierra I didn't format the drive as APFS, it is APFS now, so that's my suspicion. Anyway, all's well that ends well, except my Madonna collection (which I will now restore from the CCC backup, one subfolder after another, and see what happens). Thanks @Venderious, without you it wouldn't occur to me to look at console, much less the other command!
     
  7. Baldlars macrumors newbie

    Joined:
    Oct 5, 2018
    #7
    You may not like the solution I found ... I had the same problem ... I spent days trying to get Apple's attention on this matter, they don't seem to care. Well, I tired most of the suggested remedies from the web, but none of them worked.

    I finally had enough (to hell with waiting for Apple to get off their butt) and erased my external hard drive and on a whim formatted it as MacOS Extended (Case Sensitive, Journaled). Unfortunately, the process deleted all my old backup files, but my Time Machine now works.

    Hope this helps.
     
  8. PWC1141 macrumors newbie

    PWC1141

    Joined:
    Oct 9, 2018
    Location:
    Pattaya, Thailand
    #8
    Oops, I started a new thread on this but just saw this thread. The option above re case sensitive formatting worked for me and I am relieved after multiple failed attempts to finally do a full back up. Thanks for the tip !!!
     
  9. yukari macrumors 6502

    yukari

    Joined:
    Jun 29, 2010
    #9
    Apparently this problem occurs if you have App Cleaner software. See: https://discussions.apple.com/thread/8561149
    Specifically:

    -- (start quote)
    Oct 6, 2018 12:01 PM in response to namuang26

    Hi guys,

    I'm the developer of this application.


    I apologize for the inconvenience you could have with the issue.

    We have prepared the application update with the bug fix and sent it to App Store. Now App Cleaner v.6.2 update is being reviewed by Apple. I hope Apple will approve and release the update to App Store in a few days.

    Since update v.6.2 is released and launched the folders will be removed, the issue will disappear.


    Now, there is a simple way to bypass the issue - just add the folder

    "~/Library/Containers/com.nektony.App-Cleaner"

    to Time Machine exclude list.


    The detailed guide how to exclude the folder from backups that is available on our website

    https://nektony.com/mac-app-cleaner/troubleshooting


    Regards,

    Serge
    -- (end quote)
     
  10. navaira, Oct 15, 2018
    Last edited: Oct 15, 2018

    navaira thread starter macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #10
    Damn! I do have AppCleaner...but I don't have this folder :S Also, I have 3.4 and apparently that's the newest version...?

    Thanks for this post!
     
  11. yukari macrumors 6502

    yukari

    Joined:
    Jun 29, 2010
    #11
    Glad I can help.
    I added that folder to my excluded list and voila! It worked without any problem.
     
  12. photoj2754 macrumors 6502

    photoj2754

    Joined:
    Oct 10, 2013
    Location:
    Akron
    #12
    I don’t have that folder and have deleted the app but Time Machine still won't finish a back up.
     
  13. scgf macrumors regular

    Joined:
    Aug 12, 2003
    Location:
    Market Harborough, UK
    #13
    I was having issues with Time Machine too. Frequent errors saying it couldn't access the sparsebundle (error 112) but every time I initiated a manual Time Machine backup it worked. I decided to try turning off sleep mode - and I have had no problems since then. I have a 2017 iMac and it would appear that Power Nap is not working as it should, om my machine at least.
     
  14. macdaddy44, Dec 16, 2018
    Last edited: Dec 17, 2018

    macdaddy44 macrumors newbie

    macdaddy44

    Joined:
    Nov 17, 2018
    Location:
    Los Angeles
    #14
    I changed the IPv6 setting on the traget system to Link-local only and that fixed my problem. This started with the 10.14.2 update which seems to have introduced a bunch of network related issues.
     
  15. dilinger macrumors newbie

    Joined:
    Mar 21, 2016
    #15
    I have this app and follow the guide here:
    Way 1. Remove the folder “~/Library/Containers/com.nektony.App-Cleaner” manually.
    Then you can use App Cleaner 6.0. The issue will gone.

    Way 2. Download and launch App Cleaner the latest update from our website – https://nektony.com/download/app-cleaner-pro/app-cleaner-pro.dmg.
    Download and launch this app just once, it will remove conflicting folders.
    Then you can use App Cleaner 6.0. The issue will gone.

    Way 3. Add the “~/Library/Containers/com.nektony.App-Cleaner” folder to Time Machine exclude list, so the backup software will skip this folder making backup.
    There is the detailed instruction below how to do that.

    Do i have to do WAY 2 and WAY 3 or just WAY 2?

    i downloaded the 6.0 version but i got a notification that now there is version 6.4
    Plus i have to pay again for the PRO edition, although i have already paid for PRO?

    And in addition just to be safe i excluded the ~/Library/Containers/com.nektony.App-Cleaner from Time Machine, although i am not sure if this is also necessary.

    Please send me your feedback.

    also i noticed that the folder ''containers'' is included ONLY in the Library under user name... and not in the other 2 Library folders of my /mac.
     
  16. CTHarrryH macrumors 68000

    Joined:
    Jul 4, 2012
    #16
    I had this error and haven't re-installed App Cleaner even though I really liked it. Supposedly the latest version doesn't have this problem (also supposedly only happened when you went from version 5 to 6. Anybody installed the latest and does it work fine now.
     
  17. Holdensme macrumors newbie

    Joined:
    Apr 21, 2019
    Location:
    Florida
    #17
    I can confirm this...somewhere in my attempts to downgrade my Mini from Mojave to Sierra, the Mini told me that the back-up had to be configured as "Case Sensitive, Journaled" whether it was HFS+ or APFS formatting.
     

Share This Page

16 October 4, 2018