respring in Cydia hanging

Discussion in 'Jailbreaks and iOS Hacks' started by From A Buick 8, Jul 16, 2012.

  1. From A Buick 8 macrumors 68040

    From A Buick 8

    Joined:
    Sep 16, 2010
    Location:
    Ky Close to CinCinnati
    #1
    I tried to update and app last night through Cydia and then this afternoon i added the app "SwipeSelection" and both times it appreared to install, and then i received the prompt to respring and when i did so it hung up on the respring, after about 30 min i did a hard power off (not sure what it is called, hold the home key and the power key at the same time). Was able to get the phone working but it does not look like the app installed, any ideas.

    I jailbroke using Absetine.
     
  2. ZCherub macrumors 6502a

    ZCherub

    Joined:
    Jul 7, 2010
    Location:
    GA, USA
    #2
    Go to manage packages in Cydia? Is it there? If so, uninstall, and re-install from Cydia. If it's not, just try the install/respring again.
     
  3. From A Buick 8 thread starter macrumors 68040

    From A Buick 8

    Joined:
    Sep 16, 2010
    Location:
    Ky Close to CinCinnati
    #3
    What about the respring hanging up, seems to happen every time I do anything in cydia that requires a respring.
     
  4. ZCherub macrumors 6502a

    ZCherub

    Joined:
    Jul 7, 2010
    Location:
    GA, USA
    #4
    Package causing a conflict? Try ininstalling the last few you downloaded. If you still get the hang up on respring, try restoring.
     
  5. philip in al macrumors regular

    Joined:
    Jun 23, 2010
    #5
    A Buick 8, what cydia apps do you have? I have too many here to list, but I am having the exact same error. Maybe we can narrow it down.
     
  6. From A Buick 8 thread starter macrumors 68040

    From A Buick 8

    Joined:
    Sep 16, 2010
    Location:
    Ky Close to CinCinnati
    #6
    I deleted a couple of my newer ones, and thought that fixed it, but this morning there was a springtomize update and it again hung up on re-spring after i updated springtomize (not saying springtomize is the issue).

    Here is what i have.
    Action menu
    Activator
    AppInfo
    Folder Enhancer
    Infinidock
    iRetina++
    LockInfo
    Springtomize
    StatusBarCustomClock4
    TeatherMe
    Update Hider
    Weather Icon
    SBSettings
    My3G
    LocationHolic
    ifile
    biteSMS
    PandoraSkips
    ProTube
    SwipeSelction
    WeatherIcon
     
  7. philip in al macrumors regular

    Joined:
    Jun 23, 2010
    #7
    Let me put together a list of our common tweaks. My iPad does the same, so I'll only list the tweaks that appear on all three devices.
     
  8. philip in al macrumors regular

    Joined:
    Jun 23, 2010
    #8
    Here is what all three devices have in common:

    Action menu
    Activator
    Folder Enhancer
    Lockinfo
    Springtomize
    I file
    Swipeselction

    I don't believe that activator or lockinfo
    Are the problem.
     
  9. dotducky macrumors newbie

    Joined:
    Jun 7, 2012
    #9
    Mine did the same before I swapped to the newest iOS 6 beta (been swapping back and forth lol) ANYWAYS, the only common tweaks I have to you two are springtomize and activator... seems activator or cydia (server side) is the issue here.
     
  10. philip in al macrumors regular

    Joined:
    Jun 23, 2010
    #10
    While we all three have springtomize, mine has remained disabled for months. That may suggest that the one problem maybe activator.
     
  11. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
    #11
    I'm having the same problem. I have each of these apps except Swipeselction, so can that be ruled out?

    Anyone solve this yet?
     
  12. philip in al macrumors regular

    Joined:
    Jun 23, 2010
    #12
    So far, it appears that activator may be the issue. Can anyone remember when the last time activator was updated?
     
  13. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #13
    Via cydia
    April 1st 2012 version 1.6.2

    updates this version btw a ton of us are using activator with no issues..
    Support iOS 5.1
    Add Pause and Play actions
    Add Headset Connected/Disconnected Events
    Use much simpler native gestures on iOS5 (should fix numerous gesture-related bugs)
    Fix delayed headset action crash on iOS5
    Dismiss notification center when activating first page
    Make Activate Assistant action dismiss if assistant is already visible
    Suppress single press home button if assistant or voice controls are visible
    Add icons to menus
    Updated localizations
    Describe menus with the list of their contents
    Indicate events that don’t have anything assigned by a lighter subtitle text color
    Show placeholder icon while real icons are loading
    Fix down/up and up/down volume events actions not resetting the volume
    Fix crash when assigned menu item is uninstalled (1.6.2 beta 1 regression)
    Improve settings pane load time
    Properly reset slide gestures count when event mode changes
    Abort slide gestures when device is locked/unlocked
    Make settings commit immediately
    Support Show Volume Bar on iPad/iOS5
    Fix unable to add items to menus with a blank name
    Fix LaunchServices warnings in settings panes
    Categorize web clips into their own section
    Update icons
    Properly handle touches cancelled on statusbar
    Fix crash on iOS3 when action icon is missing
    Add requires-no-touch-events info key so that actions can defer receiving events until after touches finish
     
  14. FingerCramp macrumors newbie

    Joined:
    Jul 31, 2012
    #14
    Activator?

    So I've been having the same problem. I've had an update in my queue to be installed ("Quick Reply for WhatsApp"), and each time I try to install the update and respring, the respring hangs and when I reboot the update for the app has not installed.

    Then, based on the messages in this forum, I uninstalled Activator. Now, my device does not hang during respring (yay!) but the damn "Quick Reply for WhatsApp" still does not update (even though it says it was installed successfully).

    So, I'm guessing these are two different (unrelated) problems, and it was Activator causing the hang-on-respring problem.

    -Mike
     
  15. Kaiser99 macrumors member

    Joined:
    Jun 12, 2012
    #15
    I am also having a problem with hanging during respring it's failed twice with me once while updating swipeselection and once last night while installing swipeback (both very handy apps). What I'm seeing is the spinning cog keeps spinning and I have to hold the power and home button until it goes off and restart. Apps I've had installed

    Swipeselection
    5 row customisable keyboard (now deleted due to lagging keyboard)
    Weecloseapps
    Mobile Terminal
    Ncsettings
    Simpledate for NC
     
  16. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
    #16
    removed activator (which also removes sbsettings) and reinstalled sbsettings. no longer hangs on respring.
     

Share This Page